Bug 28481 - NFS locking (rpc.statd) broken with kernel 2.2.17-14 (workaround included)
NFS locking (rpc.statd) broken with kernel 2.2.17-14 (workaround included)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Pete Zaitcev
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-20 13:56 EST by Philip Spencer
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 14:29:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Spencer 2001-02-20 13:56:05 EST
With the current kernel and glibc combination (kernel 2.2.17 / glibc
2.2-12), rpc.statd does not work. It logs "gethostbyname error" messages
when looking up its own host name. The resolver appears to be trying to
look in /etc/hosts and fails when this inaccessible due to the chrooting of
rpc.statd. A second problem is that rpc.statd logs messages to systlog in
UTC instead of the local timezone, presumably due to the inaccessibility of
/etc/localtime.

There is a line in the statd.c source file which indicates that this was a
problem before
and a fix was attempted by calling sethostent(1) before chrooting:

  /* Arm the ****** resolver before chroot() so it doesn't fail
   * trying to open /etc/* for the dozenth time
   */
  sethostent(1);

However, this fix no longer works with the current kernel / glibc
combination (at least not on our systems). It also doesn't address the
problem with the incorrect times in the system log.

We have temporarily worked around the problem by creating a directory
/var/lib/nfs/statd/etc and putting copies of /etc/resolv.conf, /etc/hosts,
and /etc/localtime there. This fixes both of the above-mentioned problems.
However this is a suboptimal solution since it means maintaining two
separate copies of each of these files, and who knows what else rpc.statd
might be missing out on.
Comment 1 Bob Matthews 2001-02-26 12:48:04 EST
Fixed in current version of nfs-utils (0.2.1).

Note You need to log in before you can comment on or make changes to this bug.