Bug 28484 - i8000 won't resume properly after a suspend
Summary: i8000 won't resume properly after a suspend
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-20 19:14 UTC by Dan Taylor
Modified: 2007-04-18 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-20 15:57:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Taylor 2001-02-20 19:14:32 UTC
Dell Inspiron 8000/with ATI Mobility M4, after returning from Suspend to 
Disk, X runs extremely slow (slow redraws).  In VC1 when switching 
runlevels we get:
"MTRR not used"

--------------/var/log/messages------------
Feb 20 09:58:33 localhost netfs: Mounting other filesystems:  succeeded
Feb 20 09:58:34 localhost apmd[699]: Normal Resume after 00:02:31 (100% 
5:45) AC power
Feb 20 10:00:12 localhost login(pam_unix)[991]: session opened for user 
root by LOGIN(uid=0)
Feb 20 10:00:12 localhost  -- root[991]: ROOT LOGIN ON tty1
Feb 20 10:00:15 localhost gdm(pam_unix)[1007]: session closed for user root
Feb 20 10:00:15 localhost gnome-name-server[1126]: input condition is: 
0x11, exiting
Feb 20 10:00:15 localhost kernel: [drm:drm_release] *ERROR* Process 1006 
dead, freeing lock for context 1
Feb 20 10:00:15 localhost kernel: mtrr: MTRR 3 not used
Feb 20 10:00:15 localhost kernel: mtrr: MTRR 3 not used
Feb 20 10:00:15 localhost kernel: mtrr: reg 3 not used
------------

Adding "alias agpgart off" to /etc/modules.conf resolves the issue.

Comment 1 Bernhard Rosenkraenzer 2001-03-06 19:27:53 UTC
This is either a problem with your BIOS or a kernel bug. I tend to believe 
it's the former, no problems whatsoever here with a Gericom 3xC.


Comment 2 Michael K. Johnson 2001-03-12 19:25:05 UTC
I agree with bero, this looks very much like a BIOS bug to me; it
looks like the BIOS is not restoring agp state correctly.  Please
check with your APM BIOS implementors on this one.

Comment 3 Rogelio Noriega 2001-05-10 19:17:31 UTC
The system will now properly resume from suspend to ram and suspend to
disk without video slowdown.  However, after a resume when trying to run
gears, the system will lock up.


Comment 4 Arjan van de Ven 2001-05-16 17:16:31 UTC
gears is the DRI screensaver, right ?


comparing "lspci -vxxx" before and after the suspend would be interesting;
I wouldn't be surprised if the bios doesn't restore AGP state exactly

Comment 5 Alan Cox 2001-05-28 17:45:47 UTC
When I looked at this before the 8000 seemed to be leaving the AGP state trashed
across a power management event and also not restoring the MTRR registers.

The current tree has agp save/restore hooks if we know what needs to be saved
and restored...


Comment 6 David Woodhouse 2001-07-20 15:57:18 UTC
I8000 laptop here even without X doesn't survive a suspend at all. The screen
comes back but the kernel appears completely dead - the 'apm -s' command doesn't
return and keyboard/mouse/network are dead. Probably dying in an IRQ storm?

Ironically, it does actually manage to survive a suspend-to-disk. And even more
strangely, once it's survived a suspend-to-disk the APM suspend also starts to
mostly work, until the next reboot.

I say 'mostly' because the IRQ of the built-in Ethernet seems to go AWOL after
the APM suspend - although it was working OK after the suspend-to-disk; only
subsequent APM suspend breaks it.

This is with the latest (A12) BIOS.


Note You need to log in before you can comment on or make changes to this bug.