Bug 28487 - RawHide XFree86 4.0.2 source package non-buildable because mga_g450.pll.c is broken
Summary: RawHide XFree86 4.0.2 source package non-buildable because mga_g450.pll.c is ...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-20 19:28 UTC by Philip J. Hollenback
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 19:28:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Philip J. Hollenback 2001-02-20 19:28:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)


I'm attempting to rebuild the XFree86 4.0.2 source rpm from
ftp://ftp.redhat.com/pub/rawhide/SRPMS/SRPMS/XFree86-4.0.2-6.src.rpm
on a redhat 6.2 system.  It fails because the file
xc/programs/Xserver/hw/xfree86/drivers/mga/mga_g450pll.c is a dos text
file.

Reproducible: Always
Steps to Reproduce:
1. run rpm --rebuild XFree86-4.0.2-6.src.rpm
	

Actual Results:  make fails on mga_g450pll.c with error messages about
"unexpected newlines".

Expected Results:  make should run to completion and give me a new source
rpm.

I'm trying to get this source rpm rebuilt for rh62.  I have XFree86 402
installed from the XFree86.org web site to do this.

Basically I think the patch that creates mga_g450pll.c is bad, and anyone
who attempts to rebuild this source rpm will have the same problem.

Comment 1 Mike A. Harris 2001-02-20 19:43:00 UTC
This is a known glitch with the patches Matrox sent us for that release
and has been corrected since then.  The current Matrox patches in my
latest tree still do not completely work yet, but we're working on it.

Do not file bugs against Rawhide packages in Red Hat 6.2 please.  They
should be filed against RAWHIDE.  Before filing a bug against Rawhide, you
should always check the absolute latest Rawhide packages to see if the
bug has been fixed already. You might also want to experiment with my
personal package releases on ftp://people.redhat.com/mharris/XFree86 which
are usually more current than Rawhide.  I release them there first for
people to test, which then gets fed into rawhide.

Thanks for pointing this glitch out, nonetheless!




Note You need to log in before you can comment on or make changes to this bug.