Bug 285101 - USB printer port with wrong ownership/permissions
USB printer port with wrong ownership/permissions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 17:01 EDT by Horst H. von Brand
Modified: 2008-06-16 10:28 EDT (History)
0 users

See Also:
Fixed In Version: hal-0.5.11-1.fc10.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 10:28:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2007-09-10 17:01:50 EDT
Description of problem:
Booting Linux, I can't use the USB printer. The problem is that
/proc/bus/usb/???/??? belongs to root:root, and no group write.

It should be group lp, rw for group. After fixing this, cups has to be restarted.

Version-Release number of selected component (if applicable):
kernel-2.6.23-0.164.rc5.fc8

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Has happened for several kernels
Comment 1 Pete Zaitcev 2007-09-10 18:12:19 EDT
Don't look at me, it has nothing to look with the kernel. Some time ago
(like, about a month) and update was pushed out which completely broke
this kind of ownership arrangement. Now there's not a single file owned
by a user other than root in the whole /dev. As a result, sound does not
work on my laptop. I'm pretty sure it's the same thing with you.
Comment 2 Pete Zaitcev 2007-09-10 18:24:46 EDT
On second thought maybe I was wrong, because printer is not owned by the
console user. Please see bug 259141.
Comment 3 Horst H. von Brand 2008-01-09 14:56:17 EST
This used to work for a while, now (kernel-2.6.24-0.138.rc7.fc9,
cups-1.3.5-1.fc9, hplip-2.7.10-3.fc9) it is again broken.

Note that the affected files (/dev/bus/usb/???/???) are certainly auto-generated
by the kernel + udev.
Comment 4 Pete Zaitcev 2008-01-09 16:49:26 EST
I'm throwing this bug over to udev, or it will never get any attention.
Like I said, kernel does not know anything about permissions of device
files (it only sets default permissions for /sys but not device nodes).
Comment 5 Harald Hoyer 2008-01-10 06:31:28 EST
should be fixed with udev-118

also note that you have to look at the ACLs for the device nodes. PolicyKit/HAL
sets ACLs for the console user.

# getfacl /dev/bus/usb/*/*
Comment 6 Horst H. von Brand 2008-01-10 12:25:38 EST
Yep, fixed by udev-118-1.fc9 here.

Note that "console user" is a non-issue here, the machine has no such user most
of the time. It shows no special ACLs in any case (just root logged in via tty).
Comment 7 Horst H. von Brand 2008-03-26 20:14:41 EDT
Broken again with udev-118-11.fc9.x86_64. Same sympthoms as before, the relevant
daemons are running now.
Comment 8 Harald Hoyer 2008-03-26 21:41:04 EDT
the facls should be set by HAL
Comment 9 Horst H. von Brand 2008-03-27 19:07:21 EDT
avahi-daemon, haldaemon, messagebus are all running.

Is there some logfile?
Comment 10 Horst H. von Brand 2008-03-30 18:51:59 EDT
Currently hal-0.5.11-0.2.rc2.fc9.i386, installed 20080322
Comment 11 Bug Zapper 2008-05-13 23:13:12 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Horst H. von Brand 2008-06-01 19:22:10 EDT
hal-0.5.11-1.fc10.x86_64, and it has been working fine for a while now.

Close this one?

Note You need to log in before you can comment on or make changes to this bug.