This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 285131 - evolution crashes after closing it
evolution crashes after closing it
Status: CLOSED DUPLICATE of bug 278171
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 17:15 EDT by Martin Jürgens
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.10.3-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 09:36:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (5.07 KB, text/plain)
2007-09-10 17:15 EDT, Martin Jürgens
no flags Details
new backtrace (5.16 KB, text/plain)
2007-09-18 01:25 EDT, Martin Jürgens
no flags Details
Backtrace with all debugging symbols asked for (4.45 KB, text/plain)
2007-09-18 17:21 EDT, Martin Jürgens
no flags Details
New F8 backtrace (9.25 KB, text/plain)
2007-11-16 11:44 EST, Martin Jürgens
no flags Details

  None (edit)
Description Martin Jürgens 2007-09-10 17:15:37 EDT
Description of problem:
evolution crashes after closing it.

Version-Release number of selected component (if applicable):


How reproducible:
sometimes

Steps to Reproduce:
1. open evolution
2. read mails
3. close it
  
Actual results:
bug buddy appears saying that evolution crashed

Expected results:
no bug buddy message.

Additional info:
i am using imap. i think that it crashes when writing something to the imap server.
Comment 1 Martin Jürgens 2007-09-10 17:15:37 EDT
Created attachment 192071 [details]
backtrace
Comment 2 Matthew Barnes 2007-09-10 21:40:49 EDT
Can you please post the results of the following command:

   rpm -q evolution evolution-data-server
Comment 3 Martin Jürgens 2007-09-11 01:34:08 EDT
evolution-2.10.3-2.fc7
evolution-data-server-1.10.3.1-2.fc7
Comment 4 Matthew Barnes 2007-09-11 11:17:30 EDT
I'm not sure of this, but I suspect the evolution-2.10.3-3.fc7 update that's in
Updates Testing might fix your crash.  It's been sitting there for awhile now so
I'm going to request it be moved to normal Fedora Updates.

Please let me know whether it fixes the crashes for you.
Comment 5 Matthew Barnes 2007-09-11 11:37:58 EDT
Actually the update is -4.fc7, not -3.fc7.
Comment 6 Martin Jürgens 2007-09-13 17:48:52 EDT
Thanks, I just noticed that 2.10.3-4.fc7 went into the archives. I will leave a
note in some days saying if it crashed again.
Comment 7 Martin Jürgens 2007-09-15 05:48:24 EDT
I did not encounter the issue so I guess it has been fixed. If it reappears
again, I will reopen.
Comment 8 Martin Jürgens 2007-09-18 01:23:09 EDT
Reappeard to me. 

evolution-2.10.3-4.fc7
evolution-data-server-1.10.3.1-2.fc7

Crashlog attached, although I do not see any changes.
Comment 9 Martin Jürgens 2007-09-18 01:25:26 EDT
Created attachment 198061 [details]
new backtrace
Comment 10 Matthew Barnes 2007-09-18 08:18:59 EDT
Hmm, this looks like a different bug than what I thought.

Can you please install a few debuginfo packages and post a new backtrace when
you see the crash again?

   evolution-data-server-debuginfo
   evolution-debuginfo
   glib2-debuginfo
Comment 11 Martin Jürgens 2007-09-18 10:49:17 EDT
I already have evolution-data-server-debuginfo evolution-debuginfo installed,
but I was missing glib2-debuginfo which I just have installed. Let's wait for
another crash ;)
Comment 12 Martin Jürgens 2007-09-18 17:21:27 EDT
Created attachment 198861 [details]
Backtrace with all debugging symbols asked for
Comment 13 Matthew Barnes 2007-09-18 18:04:41 EDT
Strange.  This is an entirely different crash than the first two backtraces. 
There's hardly anything Evolution-related here.  The crash almost looks like
it's occurring in libresolv.so during glibc shutdown.
Comment 14 Martin Jürgens 2007-11-16 11:44:01 EST
Created attachment 261471 [details]
New F8 backtrace

Happened again using F8
Comment 15 Milan Crha 2007-11-22 05:35:34 EST
Matt, based on the last stack trace, looks like bug 278171, what do you think?
Comment 16 Matthew Barnes 2007-11-22 09:36:59 EST
It is.  Closing as a duplicate.

*** This bug has been marked as a duplicate of 278171 ***

Note You need to log in before you can comment on or make changes to this bug.