Bug 28530 - matroxfb_base.h has an invalid 'struct display global_disp'
Summary: matroxfb_base.h has an invalid 'struct display global_disp'
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-21 02:59 UTC by Rex Basham
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 08:33:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Basham 2001-02-21 02:59:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


Genning a kernel with fisher.  It fails in the make modules with a multiply
defined global_disp in matroxfb_accel.o, matroxfb_base.o,
matroxfb_DAC1064.o, and matroxfb_misc.o.  Problem is caused by the 'struct
display global_disp' in the matroxfb_base.h header file.  If you remove the
line from the header file and add it to the matroxfb_base.c file,
everything compiles and runs fine.

Reproducible: Always
Steps to Reproduce:
1. make config and select frame buffer support for Matrox acceleration
(yeah, I know it's experimental)
2. Select G100/G200/G400/G450 support
3. No for multihead support
4. make dep ; make clean ; make modules ; make modules_install ; make
bzImage ; make install
	

Actual Results:  It will fail in the make modules step.  With the indicated
header file and c source changes, it works and you get a bootable kernel. 
It seems to be running just fine.

Expected Results:  The compile should have completed without the errors for
multiply defined symbols.

Comment 1 Arjan van de Ven 2001-02-21 08:58:21 UTC
This is fixed in the next kernel build. If a kernel version of 2.4.1-0.1.9 or
later doesn't fix it for you, please reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.