This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 285361 - vbetool does not build on ppc, ppc 64, sparcv9 or sparc64
vbetool does not build on ppc, ppc 64, sparcv9 or sparc64
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: vbetool (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: F-ExcludeArch-ppc FE-ExcludeArch-ppc64 F-ExcludeArch-SPARC
  Show dependency treegraph
 
Reported: 2007-09-10 19:08 EDT by Till Maas
Modified: 2012-06-20 18:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 18:37:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ppc build.log from a scratch build on Fedora's Koji (9.29 KB, text/plain)
2007-09-11 18:17 EDT, Till Maas
no flags Details
ppc64 build.log from a scratch build on Fedora's Koji (9.61 KB, text/plain)
2007-09-11 18:29 EDT, Till Maas
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 283491 None None None Never

  None (edit)
Description Till Maas 2007-09-10 19:08:16 EDT
vbetool does not build on ppc and ppc64, maybe because ppc and ppc64 do not have
a PC bios? Debian does not provide a package for ppc or ppc64, too:
http://packages.debian.org/testing/vbetool
Comment 1 Mamoru TASAKA 2007-09-11 01:14:18 EDT
This causes the result that pm-utils cannot be installed on
ppc, ppc64.

Would you change vbetool requirement of pm-utils to arch dependent.
i.e.
%ifnarch ppc ppc64
Requires: vbetool
%endif
?
Comment 2 Mamoru TASAKA 2007-09-11 01:21:49 EDT
Note: 

This will also cause the problem that many GNOME related
packages cannot be rebuilt because:

* libgnome-devel requires gnome-vfs2-devel
* gnome-vfs2-devel requires hal-devel
* hal-devel requires hal
* and hal requires pm-utils
Comment 3 Till Maas 2007-09-11 04:07:34 EDT
(In reply to comment #1)
> This causes the result that pm-utils cannot be installed on
> ppc, ppc64.
> 
> Would you change vbetool requirement of pm-utils to arch dependent.
> i.e.
> %ifnarch ppc ppc64
> Requires: vbetool
> %endif

This is done now.
Comment 4 Till Maas 2007-09-11 04:18:59 EDT
(In reply to comment #3)
> (In reply to comment #1)
> > This causes the result that pm-utils cannot be installed on
> > ppc, ppc64.
> > 
> > Would you change vbetool requirement of pm-utils to arch dependent.
> > i.e.
> > %ifnarch ppc ppc64
> > Requires: vbetool
> > %endif
> 
> This is done now.

But this does not work, see:
http://koji.fedoraproject.org/koji/getfile?taskID=155137&name=root.log
Comment 5 Mamoru TASAKA 2007-09-11 04:33:59 EDT
This is because hal-devel requires hal, then pm-utils
but the "bad" pm-utils is already dist-f8 buildrepo.. argh...

For this situation, I cannot do anything. Please mail to rel-eng team 
what is happening and ask them to untag "bad" pm-utils (0.99.4-1.fc8)
and get pm-utils back to 0.99.3-11.fc8 temporarily.
Comment 6 Till Maas 2007-09-11 05:00:27 EDT
Thank you very much, I asked for untagging it.
Comment 7 Till Maas 2007-09-11 10:16:31 EDT
Untagging and rebuild is done:
http://koji.fedoraproject.org/koji/buildinfo?buildID=18301
Comment 8 Mamoru TASAKA 2007-09-11 10:24:48 EDT
Thanks.
Comment 9 Till Maas 2007-09-11 18:17:09 EDT
Created attachment 193071 [details]
ppc build.log from a scratch build on Fedora's Koji
Comment 10 Till Maas 2007-09-11 18:27:25 EDT
From ppc build.log:
117 vbetool.c:19:20: error: sys/io.h: No such file or directory

flashrom's build also complains about a missing sys/io.h: #283491 and maybe #240499

The ppc64 build.log complains a lot more, but it includes a missing sys/io.h.
Comment 11 Till Maas 2007-09-11 18:29:35 EDT
Created attachment 193081 [details]
ppc64 build.log from a scratch build on Fedora's Koji
Comment 12 Bug Zapper 2008-04-04 09:48:39 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 13 Mamoru TASAKA 2008-04-04 09:59:52 EDT
FE-ExcludeArch-ppc or FE-ExcludeArch-ppc64 bug must not be
closed until resolved.
Comment 14 Bug Zapper 2008-05-13 23:13:19 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Till Maas 2008-11-06 16:54:01 EST
I don't know how to fix this or whether this is really an application that should be ported to ppc (which I doubt), therefore I set it assigned to nobody to show this.

If someone knows that this package would be useful on ppc, please explain and set the state to ASSIGNED. If you want, you can also provide a patch. :-)
Comment 16 Dennis Gilmore 2009-01-14 16:03:40 EST
it doesnt build on sparc arches for the same reason as ppc.  this ackage might be better off being ExclusiveArch for the arches that ship sys/io.h
Comment 17 Till Maas 2009-01-14 16:55:43 EST
(In reply to comment #16)
> it doesnt build on sparc arches for the same reason as ppc.  this ackage might
> be better off being ExclusiveArch for the arches that ship sys/io.h

So can this bug be closed as CANTFIX? And which arches ship sys/io.h?
Comment 18 Till Maas 2012-06-20 18:37:32 EDT
vbetool is deprecated in Rawhide (F19).

Note You need to log in before you can comment on or make changes to this bug.