Bug 28614 - control-center can't be invoked from different workspaces.
Summary: control-center can't be invoked from different workspaces.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 436483
TreeView+ depends on / blocked
 
Reported: 2001-02-21 15:26 UTC by Ed McKenzie
Modified: 2008-03-07 15:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 01:06:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-02-21 15:26:44 UTC
Steps to reproduce under sawfish:

1. Open control-center.
2. Switch to a different desktop/workspace.
3. Open control-center again. It apparently tries to pop up the original
window, but it fails. There's a button in the taskbar, but it can't be
clicked. The original gnomecc remains on the first desktop.

Comment 1 Glen Foster 2001-02-21 20:34:51 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Tim Powers 2001-03-09 16:42:05 UTC
This is actually a bug in sawfish. 

I am changing the component and reassigning as per Owen's instructions.

Tim


Comment 3 Need Real Name 2001-03-20 01:23:06 UTC
It's actually due to a bug in the GNOME wm-spec. I've fixed it in sawfish anyway
as of version 0.38

Comment 4 Tim Powers 2001-03-20 15:35:53 UTC
I have built an updated sawfish package (0.38) and currently running it. I have
verified that this bug is fixed in the 0.38 release of sawfish.

Tim

Comment 5 Havoc Pennington 2001-03-22 20:55:02 UTC
So I backported a patch related to the GNOME wm spec made between 0.37 and 0.38,
but it just resulted in a really amusingly broken sawfish, so I think I picked
the wrong patch to backport. ;-) John can you tell me which file this is in?


Comment 6 Need Real Name 2001-03-22 23:45:19 UTC
The relative changes were made in revisions 1.69 and 1.70 of the file
lisp/sawfish/wm/state/gnome.jl

Comment 7 Havoc Pennington 2001-03-23 01:06:13 UTC
OK, I think I put in only the 1.69 diff, I'll try adding the 1.70 stuff too and
see if it works.
http://cvs.gnome.org/bonsai/cvslog.cgi?file=sawfish/lisp/sawfish/wm/state/gnome.jl&rev=&root=/cvs/gnome

Thanks for the help!


Comment 8 Havoc Pennington 2001-07-12 20:10:45 UTC
We have 0.38 in rawhide now, so fixed. (Of course we broke the control center in
other ways, but...)


Note You need to log in before you can comment on or make changes to this bug.