Bug 286171 - fetchmail complains about another fetchmail running
fetchmail complains about another fetchmail running
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fetchmail (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 11:20 EDT by n0dalus
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 04:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description n0dalus 2007-09-11 11:20:10 EDT
Description of problem:
I have a cronjob that recently has been outputting an error every time it runs
(using fetchmail):
fetchmail: can't poll specified hosts with another fetchmail running at <number>.

The problem is, there is definitely no other fetchmail running, and there is no
stale .fetchmail.pid file lying around. To make matters more complicated, I am
unable to reproduce this outside of a cronjob. Running fetchmail directly on the
shell produces no error message.

Here is the cron entry:

*/5 * * * * fetchmail myserver > /dev/null

I have had no problems until the update to fetchmail-6.3.7-2.fc7, at which point
the problem has occurred every time the cronjob runs.

I put an strace into the cronjob (strace -o /tmp/straceout fetchmail myserver),
and it shows a successful open() for reading only of .fetchmail.pid - which
makes no sense as the file does not exist. I suspect that there is a threading
issue or something.

Version-Release number of selected component (if applicable):
fetchmail-6.3.7-2.fc7

How reproducible:
Only from the cronjob for some reason
Comment 1 n0dalus 2007-09-20 04:06:22 EDT
Found the problem - for some reason, there were two crond's running. So two
fetchmail instances were being started simultaneously every time. If it happens
again I'll file a bug against vixie-cron instead.

Apologies for the non-bug report. Closing.

Note You need to log in before you can comment on or make changes to this bug.