Bug 286221 - OpenOffice.org cannot use a custom print command from the gnome print dialog
Summary: OpenOffice.org cannot use a custom print command from the gnome print dialog
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-11 15:53 UTC by Ian Collier
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 2.3.0-6.4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 13:39:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Collier 2007-09-11 15:53:56 UTC
Description of problem:
I prefer printing with lpr instead of cups.  However, if I try to print a
document then oowriter responds with an error message instead of producing a
printout.

Version-Release number of selected component (if applicable):
2.2.0-14.11

How reproducible:
Always

Steps to Reproduce:
1. echo 'gtk-print-backends = "lpr,file"' >> /etc/gtk-2.0/gtkrc
2. oowriter
3. Type some rubbish
4. File -> Print
5. select "Print to LPR"
6. press Print
  
Actual results:
OOo UNKNOWN PRINTER "Print to LPR"
(in the terminal where oowriter was started)

Expected results:
a printed document

Comment 1 Caolan McNamara 2007-10-02 12:48:15 UTC
What we need is to be able to propogate the print command down from the dialog
to the printing backend which was missing, I've added this and it'll be in F-8,
and it will be in openoffice.org >= :2.2.1-18.3.fc7 if we do another update for F-7

Comment 2 Ian Collier 2007-10-04 14:18:12 UTC
Thanks for this.  I peeked in cvs for the code and I now have it working on my
copy.  Incidentally there seems to be a missing ')' on one of the lines.

Comment 3 Caolan McNamara 2007-10-04 14:26:17 UTC
Yeah, missing ), hope that didn't waste 8 hours of your life on a throwaway build

Comment 4 H.Breimer 2007-10-09 13:44:28 UTC
After the recent update of openoffice I have the problem that the print-dialog
accepts the order for multiple copies, but only one is printed.(Before this
update things worked as expected.C

Comment 5 Caolan McNamara 2007-11-02 13:39:43 UTC
All should be well in 2.3.0-6.4.fc7


Note You need to log in before you can comment on or make changes to this bug.