Bug 286331 - audio not working
audio not working
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 12:29 EDT by maria teresa
Modified: 2008-02-22 05:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 05:46:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
soundcard config log file (46.94 KB, text/plain)
2007-09-11 12:29 EDT, maria teresa
no flags Details

  None (edit)
Description maria teresa 2007-09-11 12:29:11 EDT
Description of problem:
audio is not working. I tried "rilevamento della scheda audio" which I guess
translates to english as "find (or config) soundcard".

I attach the  /root/scsconfig.log file
while /root/scsrun.log files is copied below:

------- System Config Soundcard Log --------
mar set 11 18:19:55 CEST 2007

aplay: main:545: audio open error: Dispositivo o risorsa occupata



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 maria teresa 2007-09-11 12:29:11 EDT
Created attachment 192671 [details]
soundcard config log file
Comment 2 Martin Stransky 2007-09-27 09:56:42 EDT
Hm, the log looks sane. Can you boot to the console and try to play sound via
aplay? see http://people.redhat.com/stransky/alsa/
Comment 3 maria teresa 2007-09-27 12:47:40 EDT
I tried aplay, but still I hear no sound.
I looked quickly at the web page you wrote above about alsa.
I will try to install new drivers, but due to my ignorance I'm not sure which
one I should choose on the list of  alsa-drivers for F7 page.
but today I was too busy to look carefully.

thanks for your help, 
mt 
Comment 4 maria teresa 2007-09-28 11:03:53 EDT
I installed today the alsa-drivers (not using rpms, I followed carefully the
steps in the ALSA support page)

Unfortunately I still hear no sound when trying with aplay.

In the installation everything went fine, only I had to change the kernel source
directory when running ./configure.
Also I got a warning message when installing libs and utils which of course
cannot be the problem, anyway the warning is the following:
$rpm -Uhv alsa-utils-1.0.14-0.8.src.rpm
   1:alsa-utils             warning: user komat does not exist - using root
in case you want to fix it (nobody is komat here, I guess it is written
somewhere in your files)

of course I did the alsaunmute command (I set volume to up to 100% to be sure!)
with the cmd: $alsaunmute 0 -v -s 100

and I have only one card:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

can it be a problem that my computer is a notebook?

I hope you can help me,
Cheers,
Maria Teresa



Comment 5 Martin Stransky 2007-10-01 07:12:04 EDT
(In reply to comment #4)
> can it be a problem that my computer is a notebook?

I don't think so.

Anyway, it looks like a kernel/driver problem. You may install the latest
drivers (ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.15rc3.tar.bz2)
from ALSA project page (www.alsa-project.org). The install process is the same.

If it doesn't help, please report it to ALSA project - they're authors of linux
sound system.
Comment 6 maria teresa 2007-11-27 10:15:45 EST
Dear Martin Stransky,
I tried (finally! I have been pretty busy), the new alsa-driver, and also from
alsa page I took new lib and utils. Configuration and installation seem all ok,
but still I have no sound. 
I sent today a report to ALSA project.
thanks,
mt
Comment 7 Martin Stransky 2008-02-22 05:46:10 EST
okay, closing as upstream.

Note You need to log in before you can comment on or make changes to this bug.