Bug 28644 - Disk Druid won't allocate partitions where requested
Summary: Disk Druid won't allocate partitions where requested
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-21 17:59 UTC by Doug Ledford
Modified: 2007-04-18 16:31 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-02-21 18:00:02 UTC


Attachments (Terms of Use)

Description Doug Ledford 2001-02-21 17:59:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-11 i686)


Given a machine with a /dev/hda, /dev/hdb, and /dev/sda, with /dev/hda
being completely full with information I want saved, anaconda's disk druid
wouldn't allow me to create partitions on /dev/hdb.  Instead, if I left
only /dev/hdb selected as an available disk when making a partition, it
would show up on /dev/sda instead.  If I selected only /dev/sda as the
available drive, then it showed up on /dev/sda like it should.  I had to go
back and use the manual fdisk method to create partitions on /dev/hdb

Reproducible: Always
Steps to Reproduce:
1.  Have system with at least three drives, hda, hdb, sda
2.  Have /dev/hda be totally full
3.  Try to create a partition on /dev/hdb for /boot
	

Actual Results:  Partition was created on /dev/sda instead of /dev/hdb

Expected Results:  Should have created a partition on /dev/hdb

Comment 1 Michael Fulbright 2001-02-21 22:56:14 UTC
/boot has to go on one of the first two drives on your system as seen by the
kernel. It sees /dev/hda as your first drive, and /dev/sda as your second. You
will need to put a /boot on either of these, or you can use a boot floppy.

Comment 2 Doug Ledford 2001-02-21 23:33:01 UTC
On the contrary, lilo has no such restriction on the placement of the /boot
partition.  It happily went onto /dev/hdb when I forced it there by using fdisk
instead of disk druid.  Furthermore, /dev/hdb *is* the second disk in the system
according to both the BIOS and the kernel.  /dev/sda is the third disk.  If this
is an aritificial limitation of disk druid, then so be it, but it should be
documented as such since the rest of lilo and the kernel are happy for things to
be set up differently.


Note You need to log in before you can comment on or make changes to this bug.