Bug 28670 - Kernel 2.2.17-14smp only detects 896MB out of 1024MB
Kernel 2.2.17-14smp only detects 896MB out of 1024MB
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-21 14:49 EST by Gernot
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 15:08:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gernot 2001-02-21 14:49:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


The BIOS detects the 1024MB correctly, but the kernel writes the following 
message to /var/log/messages:
Feb
19 14:18:55 fire kernel: Warning only 896MB will be used.

Reproducible: Didn't try

 Hi, 

My machine has 1024MB RAM installed and the BIOS also shows the 1024MB
correctly. But, Linux seems to have a problem with it as you can see at 
the below
lines: 

Feb 19 14:18:54 fire kernel: Symbols match kernel version 2.2.17. Feb 19
14:18:55 fire kernel: Loaded 27 symbols from 2 modules. Feb 19 14:18:55 
fire kernel:
Linux version 2.2.17-14smp (root@porky.devel.redhat.com) (gcc version
egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 SMP Mon Feb 5 
18:40:03 EST 2001 Feb
19 14:18:55 fire kernel: Warning only 896MB will be used. 

This is the error I get in the /var/log/messages file. The output of
/proc/meminfo is: 

total: used: free: shared: buffers: cached: Mem: 928161792 397012992 
531148800
1147170816 38400000 81252352 Swap: 808255488 0 808255488 MemTotal: 906408 
kB
MemFree: 518700 kB MemShared: 1120284 kB Buffers: 37500 kB Cached: 79348 kB
BigTotal: 0 kB BigFree: 0 kB SwapTotal: 789312 kB SwapFree: 789312 kB 

I already tried to add the appaned="mem=1024M" line to lilo.conf with no
success too. 

I'm using the standard Redhat kernel (RPM packages) 2.2.17-14smp (It's a 
Dual
CPU machine). 


This looks like it's a bug in the kernel 2.2.17-14smp. Can anyone confirm 
this?

If you need further information, please contact me ( gernot@321host-
it.com )

Thanks in advance, 

Gernot
Comment 1 Gernot 2001-02-21 15:08:25 EST
Sorry, I meant:

append="mem=1024M"

I also tried:

append="mem=1020M"
since it was suggested by a fellow technician :) Same results: none :)
Comment 2 Michael K. Johnson 2001-02-21 19:12:52 EST
Use the enterprise kernel for that

The top 128M of that 1GB of memory is reserved for kernel virtual mappings.

Note You need to log in before you can comment on or make changes to this bug.