Bug 287421 - postgresql-jdbc-Driver does not load
postgresql-jdbc-Driver does not load
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: postgresql-jdbc (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 06:00 EDT by Thomas Schweikle
Modified: 2013-07-02 23:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 04:59:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2007-09-12 06:00:01 EDT
Description of problem:
trying to use postgresql-jdbc-Driver "org.postgresql.Driver" does give 
back an error message "Driver not found".


Version-Release number of selected component (if applicable):
postgresql-jdbc-8.2.504-1jpp.fc7


How reproducible:
Everytime


Steps to Reproduce:
1. Install some java application using postgresql-jdbc.
2. Start the application.
3. Depending on the applications error handling you will see an error 
message or a trap, telling "org.postgresql.Driver" was not found.

Setting the classpath to point to "postgresql-jdbc.jar" or the file this 
link points to does not help.
  
Actual results:
The driver "org.postgresql.Driver" not found.


Expected results:
The driver "org.postgresql.Driver" should be found and loaded.


Additional info:
This is something rendering postgresql unusable with java applications.
Comment 1 Thomas Schweikle 2008-04-06 04:59:12 EDT
Could we close this, since there are updated packages available for Fedora 7 
java which solve this issue.

Note You need to log in before you can comment on or make changes to this bug.