Bug 287481 - capi20 rule blocks creation of /dev/sdbm
capi20 rule blocks creation of /dev/sdbm
Status: CLOSED DUPLICATE of bug 202792
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2007-09-12 07:14 EDT by Tom G. Christensen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-12 07:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom G. Christensen 2007-09-12 07:14:14 EDT
Description of problem:
On a machine with many SAN luns connected we ran into the problem that the udev
rule for the capi20 device prevented the creation of a block device /dev/sdbm.
This is the rule that is the problem in 50-udev.rules:
SYSFS{dev}="68:0",              NAME="capi20"

Looking at /dev/sdbm it would seem it shares a major/minor with capi20:
brw-rw----  1 root disk 68, 0 Jun 30 13:12 /dev/sdbm

Version-Release number of selected component (if applicable):

How reproducible:
So far only one machine has accumulated the required number of luns to display
the problem.
I'd expect it to be 100% reproducible.

Steps to Reproduce:
1. Attach enough block devices so you'd need /dev/sdbm
2. Watch udev create /dev/capi20 instead of /dev/sdbm
Actual results:
/dev/capi20 is created instead of /dev/sdbm.

Expected results:
/dev/sdbm is created for the block device instead of /dev/capi20.

Additional info:
The SAN luns are multipathed (4 paths pr. lun) so the number of needed devices
quickly rises which each added lun.
To illustrate we currently have 26 mpath devices using 104 block device nodes on
this particular box (about 165TB of storage).
For now we have simply removed the rule.
Comment 1 Harald Hoyer 2007-09-12 07:38:58 EDT

*** This bug has been marked as a duplicate of 202792 ***
Comment 2 Harald Hoyer 2007-09-12 07:39:59 EDT
Please test

Erratum will be build for rhel-4.6.

Note You need to log in before you can comment on or make changes to this bug.