Bug 287491 - LDAP replication from RHEL3 to RHEL4 is not working
LDAP replication from RHEL3 to RHEL4 is not working
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.0
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 07:22 EDT by Johan Dahl
Modified: 2008-01-31 09:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 09:46:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
slapd -d -1 ldap:\\\ on staff2 (slave) (387.42 KB, text/plain)
2007-09-12 07:22 EDT, Johan Dahl
no flags Details

  None (edit)
Description Johan Dahl 2007-09-12 07:22:39 EDT
Description of problem:

A server staff (RHEL 3) is a ldap master. It has two slaves: student (RHEL 3)
and staff2 (RHEL 4). Replication to student works without any problems.
Replication to staff2 fails with the error:

entry failed schema check: no structuralObjectClass operational attribute

on staff2. In the slurpd-log (/var/lib/ldap/replica/staff2.sol.lu.se\:389.rej)
says Unknown error.

Changing single attributes of existing records work as expected.

Replication is configured on staff (Master)

replica host=student.sol.lu.se:389
        binddn="uid=replicator,ou=People,dc=sol,dc=lu,dc=se"
        bindmethod=simple
        credentials=*********
replica host=staff2.sol.lu.se:389
        binddn="uid=replicator,ou=People,dc=sol,dc=lu,dc=se"
        bindmethod=simple
        credentials=*********

And on staff2 (Slave)

updatedn	uid=replicator,ou=People,dc=sol,dc=lu,dc=se
updateref	ldap://staff.sol.lu.se




Version-Release number of selected component (if applicable):
Staff (RHEL 3) openldap-2.0.27-23
Staff2 (RHEL 4) openldap-2.2.13-7.4E


How reproducible:
Always

Steps to Reproduce:
1. Start staff as a master LDAP server
2. Start staff2 as a slave LDAP server
3. Add records on staff.
4. Watch it to be added on staff2
  
Actual results:
Record is not replicated to staff2.

Expected results:
Record added to staff2


Additional info:
Comment 1 Johan Dahl 2007-09-12 07:22:39 EDT
Created attachment 193341 [details]
slapd -d -1 ldap:\\\ on staff2 (slave)
Comment 2 Johan Dahl 2007-09-12 08:37:28 EDT
I tested replicating from another server running RHEL 4 and it works. However
staff2 is going to replace staff on monday and I can't really test replicating
from RHEL4 to RHEL3 because I only got production servers running version 3.
Comment 3 Jan Safranek 2007-09-12 10:06:56 EDT
Bugzilla is not the best place to report such problem - please contact your Red
Hat support at https://www.redhat.com/apps/support/, they should definitely help
you.
Comment 4 Jan Safranek 2008-01-31 09:46:31 EST
I am afraid I am not able to reproduce the bug. Please use Red
Hat support to report such problems.

Note You need to log in before you can comment on or make changes to this bug.