Bug 28750 - openssh 2.5.1p1 enhancements
Summary: openssh 2.5.1p1 enhancements
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-21 23:10 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 18:09:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
minor fixes (10.44 KB, patch)
2001-02-21 23:11 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2001-02-21 23:10:52 UTC
Attached are a few enhancements:

 1) Jim Knoble's addresses
 2) /etc/profile.d referred to with %{_sysconfdir}/profile everywhere
 3) move reload under a new function for consistency.

Also:

should %makeinstall used instead of make install?  (note that the keys are generated
if DESTDIR exists -- no matter though as they aren't in %files)

%changelog says openssl should now be require, no prereq.  This wasn't changed.

Comment 1 Pekka Savola 2001-02-21 23:11:37 UTC
Created attachment 10720 [details]
minor fixes

Comment 2 Glen Foster 2001-02-23 21:49:25 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #2


Comment 3 Pekka Savola 2001-02-24 18:09:30 UTC
Also add:

@@ -22,6 +22,8 @@
  # rpm -ba|--rebuild --define "rh7 1"
  %{?rh7:%define redhat7 1}
  
 +%define exact_openssl_version   %(rpm -q openssl | cut -d - -f 2)
 +
  Summary: OpenSSH free Secure Shell (SSH) implementation
  Name: openssh
  Version: %{oversion}
 @@ -37,6 +39,7 @@
  BuildRoot: /tmp/openssh-%{version}-buildroot
  Obsoletes: ssh
  PreReq: openssl >= 0.9.5a
 +PreReq: openssl = %{exact_openssl_version}
  Requires: openssl >= 0.9.5a
  Requires: rpm >= 3.0.5
  BuildPreReq: perl, openssl-devel, tcp_wrappers

.. else there will be tons of bogus errors when people upgrade to openssl-0.9.6 when they shouldn't.

Comment 4 Nalin Dahyabhai 2001-02-26 17:53:16 UTC
Changes to the init script, X11 askpass, and Jim's email will be pulled into
2.5.1p1-4.

We can't add libcrypt to the link line, because OpenSSL normally provides a
crypt() implementation as well, and static linking could break this.

Using %makeinstall wouldn't help here -- setting it to "/" doesn't skip
generation of the host key, but using DESTDIR saves us from having to specify
the libexecdir and sysconfdir more than once.


Note You need to log in before you can comment on or make changes to this bug.