Bug 28751 - Installer Hangs in the end
Installer Hangs in the end
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-21 18:14 EST by Pedro Castro
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 14:28:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Castro 2001-02-21 18:14:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)


Instalation Program crashes in the end, when a single status bar appears 
after copying files.

Reproducible: Always
Steps to Reproduce:
1.start with any installtion method
2.chose anything
3.no special steps till the end
	

Actual Results:  system crashed with a "submit error" dialog screen.

Expected Results:  Setup continued successfully

Bug Copy:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1631, in 
doInstall
    self.fstab.write (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 740, in 
write
    iutil.mkdirChain(prefix + mntpoint)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 193, in 
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 5] Input/output error: '/mnt/sysimage/mnt'

Local variables in innermost frame:
which: 4
dir: /mnt/sysimage/mnt/cdrom
elements: ['', 'mnt', 'sysimage', 'mnt', 'cdrom']
path: /mnt/sysimage/mnt

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2001-02-22 11:53:23 EST
If you look at the VC3 and VC4 output (hit cntl-alt-f3 and -f4), are there any
odds looking errors messages from the kernel?
Comment 2 Pedro Castro 2001-02-22 13:43:13 EST
Before relating errors that appear at the VC3 and VC4 output, I'dd like to 
refer my drives: two HDS (One (hda)Western Digitals-4MB- and another one (hdb) 
Fujitsu-3,5mb; TWO IDE ATAPI CD-ROM: A btc cdrom 24x (hdc) and a HP CD-Writer 
Plus 8100 (hdd). I (tried to) install linux on HDB.

I Found errors:
(errors may not be written EXACTLY as they appeared, may have some mistakes)
DURING STARTING UP INSTALL:
<4> hdc error: illegal request...  faled - "Mode Select 10" - packet 
error... "50 11 10 10 10 10 10 10 18 10 10 10"

DURING PARTITIONS FORMATING:
write_intr error 1 nr_sectors=1,stat=0x51
ide reset=success
(this one appeared over 100 times (or more)during disk formating

DURING FILE COPYING:
EXT2-fs error - read-inode bitmap
cannot read inode bitmap
hdb:read_intr: status=0x59 {Drive Ready Seek Complete DataRequest Error}
hdb:read_intr: error=0x10 {Sector 10 Not Found} , LBASect = 7170631,sector=6815
(this appeared realy a lot of times)

Another note: when I try to install by copying the cd files to my HD and 
install from HD, the installation stops in the middle of the copying files part 
and lots of words and sentences appear in my screen. I have to reboot manually. 
It just gets stuck.
Comment 3 Michael Fulbright 2001-02-23 12:19:24 EST
These are hardware errors with your hard drive (hdb).

It would seem this drive is failing perhaps, or the cabling is bad?

Unfortunately it is not a problem related to the installer.
Comment 4 Pedro Castro 2001-02-23 13:15:29 EST
I've tested the drive and the cable and they seem alright! The HD works under 
Windows. I think: I used a CD-Copy of an original RedHat 7 (I lost the original 
one(s) :( ! ). Can't the error be because of not using an original cd? (My 
original Cd's worked fine on another computer I have, but I didn't even get to 
try it on this one).
Comment 5 Michael Fulbright 2001-02-27 14:28:06 EST
What type of IDE controller is the hard drive attached to?
Comment 6 Michael Fulbright 2001-04-02 15:59:43 EDT
Closing due to inactivity - please reopen if you have anything to add to the bug
report.

Note You need to log in before you can comment on or make changes to this bug.