Bug 28784 - Failure to print with HP 880C
Failure to print with HP 880C
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-21 23:31 EST by Joe Morris
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 16:10:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Morris 2001-02-21 23:31:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1 i686)


When I configure my HP 880C printer (/dev/usb/lp0) with printtool, nothing
happens.  I went to print a test page, and nothing happened.

Reproducible: Always
Steps to Reproduce:
1.Run the printtool and configure the printer as normal	

Actual Results:  My printer didn't respond when I went to print a test
page.

Expected Results:  My printer should print, as it has done flawlessly in
previous RedHat versions.

In an effort to get my HP 880C to work, I "downgraded" to RedHat 7's
printtool, and then reconfigured the printer, crossing my fingers that it
would work.  I selected "Print ASCII directly to port", and my printer
finally responded and printed out the page.  However, when I went to print
an ASCII or Postscript test page, nothing happened.  My printer has worked
flawlessly in previous releases of RedHat (6.2 and 7.0).  I also noticed
that when I selected "restart lpd" the console displayed the following
message:
Warning- stat of file 'filter' failed 'No such file or directory'
Warning- cannot stat 'if' filter '/var/spool/lpd/lp/filter' - No such file
or directory
Plugging the printer into the parallel port doesn't work, either.  Thanks
for your help guys.
Joe
Comment 1 Glen Foster 2001-02-23 16:51:29 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Crutcher Dunnavant 2001-02-28 07:39:26 EST
Hmm, the best I can do is ask for more info..

Please attach the following files, if they exist:

/etc/alchemist/namespace/printconf/local.adl (gziped XML)
/etc/printcap
/etc/printcap.save
/var/spool/lpd/?spooldir?/general.cfg
/var/spool/lpd/?spooldir?/postscript.cfg
/var/spool/lpd/?spooldir?/mf.cfg
Comment 3 Crutcher Dunnavant 2001-02-28 07:40:51 EST
Oh, by the way. Did you click 'Apply'? This saves the changes and restarts the
spool, and wasn't really pushy about it in the release you have.
Comment 4 Joe Morris 2001-03-03 09:17:24 EST
I just installed Wolverine and my printer will work with the cdj880 driver. I 
haven't tried the hpdj driver, but the cdj850 driver is distorted. When I 
selected to print a postscript test page with cdj850, it printed what looked 
like what the upper left corner of the test page should have been, but it was 
magnigied greatly (I'm sorry if I lost you, but this is difficult to explain!). 
In short, I have two huge lines going down the middle of the page. It is 
distorted. I can live with it though, as the cdj880 works well. Thank you for 
your help!
Comment 5 Arion Blishen 2001-03-06 01:23:09 EST
I also can not get the HP 880C to work using printtool.

Also there is no reference to any printer config tools in the menu at all so
most people will not find printtool.

Why doesn't RedHat use something like CUPS ?
Comment 6 Crutcher Dunnavant 2001-03-09 16:10:07 EST
I'm pretty sure this is fixed.
The problem had to do with how some options got added to postscript, I think.

Please try the rpms at:
http://people.redhat.com/crutcher/printing/

and tell me how they work.
Comment 7 Crutcher Dunnavant 2001-03-14 17:15:22 EST
I think this is fixed, reopen if it doesn;t work with the latest stuf.

Note You need to log in before you can comment on or make changes to this bug.