Bug 287931 - umbrello fails with SIGSEGV when removing Asynchronous message
umbrello fails with SIGSEGV when removing Asynchronous message
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
7
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 12:16 EDT by Petr Lautrbach
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 18:02:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Lautrbach 2007-09-12 12:16:48 EDT
Description of problem:

umbrello fails with SIGSEGV when removing Asynchronous message in Sequence diagram

Version-Release number of selected component (if applicable):
$ umbrello --version
Qt: 3.3.8
KDE: 3.5.7-20.fc7 Fedora
Umbrello UML Modeller: 1.5.7

kdesdk-3.5.7-7.fc7

How reproducible:

create 2 classes in class diagram

open Diagram -> New -> Sequence Diagram

copy classes from UML Model to Sequence diagram

choose Asynchronous message and make message from class1 to class2 - click on
line from class1 and class2 

choose Select

select created line represents asynchronous message and type <Del>

program crash

Additional info:

updated F7 on i686 and x86_64
Comment 1 Rex Dieter 2007-09-12 12:23:07 EDT
You would be better served reporting this upstream to bugs.kde.org.  (If you do,
please report back here the upstream bug # so that we can track it).
Comment 2 Petr Lautrbach 2007-09-12 13:11:45 EDT
it is fixed in
Umbrello UML Modeller: 1.5.71
downloaded from
http://prdownloads.sourceforge.net/uml/umbrello-1.5.71.tar.bz2?download
Comment 3 Rex Dieter 2007-10-30 10:35:27 EDT
Looks like this should get addressed with kde-3.5.8 coming real soon.
Comment 4 Rex Dieter 2007-11-17 18:02:12 EST
kdesdk-3.5.8 update released, closing.

Note You need to log in before you can comment on or make changes to this bug.