Bug 288 - filter for HP Deskjet 400/500C/520/540C causing errors
filter for HP Deskjet 400/500C/520/540C causing errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
5.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
: 336 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-03 21:49 EST by Brian Ryner
Modified: 2014-03-16 22:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-29 11:03:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 1998-12-03 21:49:40 EST
When I try to use this filter, I get the following error
printed:
Unrecoverable error: rangecheck in .putdeviceprops
(1488)op_array(486)0x817b0d4:E

This was with it configured for black and white printing.
My printer is a deskjet 400.  Using the Deskjet 500 driver
seems to be a workaround.
Comment 1 dclark 1998-12-05 13:11:59 EST
I get the same error using the "HP 550C/450C/6xxC series" driver for
my HP DeskJet 600C printer under RedHat 5.2. I did not have this
problem under 5.1. In addition to the error that is printed out which
is mentioned in the initial bug report, this also comes up on the
console:

stdin: is not a tty/var/spool/lpd/lp/filter: /root/general.cfg: No
such file or directory
/var/spool/lpd/lp/filter: [: asc: unary operator expected
/var/spool/lpd/lp/filter: [: printer: unary operator expected
/var/spool/lpd/lp/filter: [: printer: unary operator expected
/var/spool/lpd/lp/filter: [: ps: unary operator expected
/var/spool/lpd/lp/filter: [: ps: unary operator expected
/var/spool/lpd/lp/filter: [: printer: unary operator expected
/var/spool/lpd/lp/filter: [: printer: unary operator expected

I've tried replacing the rhs-printfilters, ghostscript,
ghostscript-fonts, printtool, and lpr packages with the RH5.1 versions
without success (However I do get different error messages when I do
this).
Comment 2 dclark 1998-12-05 14:30:59 EST
Setting the filter for 2 pagers per output page seems to make this
problem also happen under the "DeskJet 500" driver when printing the
Postscript Test Page. No console messages appear, but the

Unrecoverable error: rangecheck in .putdeviceprops
(1488)op_array(486)0x817b0d4:E

happens.
Comment 3 Bill Nottingham 1998-12-08 11:13:59 EST
Hmm. It appears the cdj550 driver for ghostscript is broken for
1bpp mode. What you can do to work around this is:

- go into the input filter settings in printtool, and set the
  'Color Depth' to 8 for B&W printing.
- use the DeskJet 500 or some other mostly-compatible driver
Comment 4 Bill Nottingham 1998-12-10 17:44:59 EST
*** Bug 288 has been marked as a duplicate of this bug. ***
... at least from netscape. I tried both Netscape 4.05-4
and  (after) I tried Communicator 4.07-1.

I am not sure if the problem is with Netscape or lpr.

I am printing locally and I can print from the command line
just fine. It even spits it out if I print after netscape
chokes on it.

It gives the error:
"Unrecoverable error: rangecheck in .putdeviceprops

(1488)op_arrray(486)0x817b0d4:E" [where it goes off the end
of the page. Also after .putdeviceprops and before (1488)
there is no carriage return]

------- Additional Comments From notting@redhat.com  12/08/98 11:06 -------
What driver are you using?

------- Additional Comments From bubar@albany.net  12/10/98 15:45 -------
I did a little testing this morning and the problem appears to be
ghostscript. I could do all kinds of Text printing but once I sent a
postscript test it balked and I had to senda text job to free it.
Comment 5 Bill Nottingham 1998-12-29 11:01:59 EST
*** This bug has been marked as a duplicate of 257 ***
Comment 6 Bill Nottingham 1998-12-29 11:03:59 EST
A workaround has been made in rhs-printfilters-1.46-4.
(For all the cdj-based drivers, the 1bpp option has been
removed.)
Comment 7 dclark 1998-12-31 08:46:59 EST
This workaround did not work for me:

dclark@djbclark:~ rpm -qa | grep printfilters
rhs-printfilters-1.46-4

I still get:
Unrecoverable error: rangecheck in .putdeviceprops
(1488)op_array(486)0x817b0d4:E
Comment 8 Bill Nottingham 1999-01-02 00:40:59 EST
Um, perhaps I need to clarify. The workaround in printfilters
only appears when configuring the printer (it removes
1bpp from the valid color depth lists). It doesn't change
the old configuration - gs will still crash if you run it
in 1bpp.

Note You need to log in before you can comment on or make changes to this bug.