Bug 28825 - Network install crashes when installing chkconfig
Network install crashes when installing chkconfig
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-22 07:17 EST by n.blackaby
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-28 11:40:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description n.blackaby 2001-02-22 07:17:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Network install (via HTTP) using text mode (floppy has bootnet.img on it). 
Install (chose Server System) goes OK until the installation of the 
chkconfig package when the screen goes red and install program bombs out.

Reproducible: Always
Steps to Reproduce:
1. Floppy has bootnet.img
2. Install via HTTP
3. Choose Server System

Actual Results:  Install crashes during install of chkconfig package.

Expected Results:  Expected installation to proceed to finish.
Comment 1 Michael Fulbright 2001-02-22 12:14:56 EST
If any messages appear on the screen when it crashes that would be very helpful
to know about.
Comment 2 n.blackaby 2001-02-23 05:14:43 EST
Messages on screen after installation program crashes out during chkconfig 
package install are:

install exited abnormally -- received signal 11
sending termination signals...done
sending kill signals ...done
disabling swap
unmounting filesystems (etc...)

The machine concerned is a relatively new Dell PowerEdge 2450 server with one 
internal 18GB SCSI disk and two ethernet cards.
Comment 3 Michael Fulbright 2001-02-23 11:31:21 EST
How much RAM is detected (you can cat /proc/meminfo from VC2 once you see the
welcome screen in the installer)?

Also, what are you running as the web server you are using to drive the HTTP

Finally, can you try a NFS or FTP install from this host?
Comment 4 n.blackaby 2001-02-26 09:23:34 EST
(i) RAM detected = 896MB -- why can't Redhat Linux be compiled to see a bit 
more than this (say at least 1GB)?

(ii) HTTP install via Apache 1.3.14 on Solaris 7 on Sun Ultra 2

(iii) HTTP fails every time (always at same place [chkconfig])
      FTP install tried and completed twice (100% success)
      NFS install worked twice and failed twice (50% success)

In more detail, it appears the HTTP install will always fail; the FTP install 
will always work whereas the NFS install will work every-other time (eg. the 
second time, the fourth time)!
Comment 5 n.blackaby 2001-02-26 09:27:31 EST
Also, the two times the NFS install failed, it failed in the _same_ place 
(during the "bind" package install).
Comment 6 Michael Fulbright 2001-02-27 18:41:17 EST
Please try with the more recent wolverine beta release.
Comment 7 n.blackaby 2001-02-28 11:40:00 EST
HTTP install runs to completion OK with latest beta (Wolverine; RH 7.0.91). It 
appears to take a lot longer to install than earlier versions of RH7 (almost 
double the time?).
Comment 8 Michael Fulbright 2001-03-01 17:58:33 EST
On SCSI systems the newer 2.4 kernels seem to have some tuning problems we're
looking at.

Noting that wolverine works for you.

Note You need to log in before you can comment on or make changes to this bug.