Bug 288381 - dependency hell at the starting gate.
dependency hell at the starting gate.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 15:51 EDT by Stephen Wooddell
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 16:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Three outputs of the rpm command (-qa, qa --last, Va) (23.83 KB, application/x-gzip)
2007-09-12 15:51 EDT, Stephen Wooddell
no flags Details

  None (edit)
Description Stephen Wooddell 2007-09-12 15:51:22 EDT
Description of problem:

After installing Fedora 8 off a LiveCD(rawhide20070904?) and running the update
GUI a few problems where introduced, but quickly fixed. The main one, Pup and/or
Yum is ignoring required dependencies without error output and installing
packages without the dependencies.

Version-Release number of selected component (if applicable):
Yum 3.2.5

How reproducible:
I've tweeked the desktop a little, but nothing else besides installing,
updating, and a few installing what should be unrelated packages.


Steps to Reproduce:
Outside using the attached files to make a kickstart, and installed packages in
their listed order? Not a clue.
  
Actual results:


Expected results:
dependency hell

Additional info:
I realy shouldn't have to run the commands 'yum -clean all', 'yum -makecache',
or most dreaded 'rpm --rebuild' and would prefer to avoid them like the plague.
Let me know if I can provide any more relevant information.
Comment 1 Stephen Wooddell 2007-09-12 15:51:22 EDT
Created attachment 193891 [details]
Three outputs of the rpm command (-qa, qa --last, Va)
Comment 2 Stephen Wooddell 2007-09-12 15:56:59 EDT
Forgot two fact, DOH! First I resolved some dependencies by using the Add/Remove
package GUI to search out and install the SDL Binaries manually.

Second, I've tried uninstalling the affected packages and reinstalling. Yum does
not pickup on the missing packages.
Comment 3 Seth Vidal 2007-09-12 16:02:35 EDT
you installed from rawhide with an older yum version, which, I believe had a
dependency handling error. yum 3.2.5 though currently installed, won't fix the
errors already existing.

yum install yum-utils

then run:

package-cleanup --problems

and see if you can install those deps by running:

yum install "dephere"

yum is fixed in rawhide (and I think in f8t2)

Comment 4 Stephen Wooddell 2007-09-12 17:55:07 EDT
Thanks for the help, it is much appreciated, just one more question. If the
rawhide rawhide-live-20070904 torrent at http://torrent.fedoraproject.org/ is
not the most update where is it?

This is the one I installed, and most up to date available. I haven't tried a
net install sense I fixed my RAM* a few days ago, there maybe?

*It was only a one or two bits off every read or two when heavily taxed, but
considering the instillation source went though RAM and everything I
updated/downloaded  had at least minor corruption I am impressed that Fedora
took and kept on trucking. I'm not happy it didn't tell me why things where
randomly erroring out, it would have cut my troubleshooting time down to a few
minuets. I'm still impressed even heavily corrupted before I found out what was
up(remembered I had the memtest program on a Knoppix disk), it operated almost
flawlessly.
Comment 5 Seth Vidal 2007-09-12 18:01:37 EDT
f8test2 will be on the torrent on thursday.


Note You need to log in before you can comment on or make changes to this bug.