Bug 2885 - PCMCIA card services can lock up on boot, possibly causing disk corruption
PCMCIA card services can lock up on boot, possibly causing disk corruption
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-17 15:23 EDT by jmoses
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmoses 1999-05-17 15:23:33 EDT
Under Redhat 6.0, it appears that pcmcia card services
3.0.9 can cause the system to lock during the boot process
on a Toshiba laptop (ToPIC 95/97 PCMCIA chipset). It
appears to occur when the following conditions are met:

1) there are no cards inserted on bootup, and
2) a "pre-install" line for pcmcia_core exists in
conf.modules.

The conf.modules line specifies that pcmcia_core is set to
load /etc/rc.d/init.d/pcmcia start. This appears to have no
effect when a card is inserted while the boot process
continues... however, if no card is inserted, the presence
of this line will cause a hard lockup.

The line in question is:

pre-install pcmcia_core /etc/rc.d/init.d/pcmcia start

This may be because the pcmcia_core module is set to load
inside that script as well. (loop?)

Several of these lockups (and subsequent forced reboots)
caused major filesystem corruption because fsck apparently
did not notice the dirty state of the filesystem on reboot
and attempted to write past the end of volumes.

Removal of this line fixed the problem satisfactorily. The
pcmcia_core module loads when the first card is inserted.
Comment 1 Michael K. Johnson 1999-08-28 14:48:59 EDT
Sure looks like a loop to me.  Bill, why do we have that?
Comment 2 Bill Nottingham 1999-08-30 10:53:59 EDT
It was intended to have PCMCIA cards work as normal cards as well;
it could probably be removed.

Note You need to log in before you can comment on or make changes to this bug.