This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 288731 - networkmanager-vpnc can never connect to the vpn service
networkmanager-vpnc can never connect to the vpn service
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-09-12 22:04 EDT by Jesse Keating
Modified: 2013-01-09 21:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 20:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-09-12 22:04:14 EDT
Seems something goes wrong in the dhcp phase, not sure if this is a vpnc
specific problem but this is a good starting point.  Here is full log:

Sep 12 22:01:04 lumos NetworkManager: <info>  Will activate VPN connection
'rhat-bos', service 'org.freedesktop.NetworkManager.vpnc', user_name 'jkeating',
vpn_data 'IPSec gateway / vpn3.redhat.com / IPSec ID / rh-vpn / NAT-Keepalive
packet interval / 10', route '172.16.0.0/16 / 192.168.76.0/22 / 10.0.0.0/8 /
192.168.32.0/22 / 192.168.6.0/22'.
Sep 12 22:01:04 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 1
of 4 (Connection Prepare) scheduled...
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 1
of 4 (Connection Prepare) ran VPN service daemon
org.freedesktop.NetworkManager.vpnc (PID 4020)
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 1
of 4 (Connection Prepare) complete.
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 2
of 4 (Connection Prepare Wait) scheduled...
Sep 12 22:01:05 lumos kernel: tun: Universal TUN/TAP device driver, 1.6
Sep 12 22:01:05 lumos kernel: tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' signaled state change 1 -> 6.
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 2
of 4 (Connection Prepare Wait) waiting...
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 2
of 4 (Connection Prepare Wait) complete.
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 3
of 4 (Connect) scheduled...
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 3
of 4 (Connect) sending connect request.
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 3
of 4 (Connect) request sent, waiting for reply...
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' signaled state change 6 -> 3.
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 3
of 4 (Connect) reply received.
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 4
of 4 (IP Config Get) timeout scheduled...
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN Activation (rhat-bos) Stage 3
of 4 (Connect) complete, waiting for IP configuration...
Sep 12 22:01:05 lumos kernel: tun0: Disabled Privacy Extensions
Sep 12 22:01:05 lumos NetworkManager: <WARN>  nm_vpn_service_process_signal():
VPN failed for service 'org.freedesktop.NetworkManager.vpnc', signal
'ConnectFailed', with message 'The VPN login failed because the VPN program
could not connect to the VPN server.'.
Sep 12 22:01:05 lumos NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' signaled state change 3 -> 6.
Sep 12 22:01:05 lumos NetworkManager: <WARN>  nm_vpn_service_stop_connection():
(VPN Service org.freedesktop.NetworkManager.vpnc): could not stop connection
'rhat-bos' because service was 6.

It's worth noting that using vpnc from the command line is successful.
Comment 1 Jesse Keating 2007-09-14 20:22:38 EDT
This seems related to my gnome keyring malfunctioning.  Now I can connect just fine.
Comment 2 Denis Leroy 2007-09-15 05:05:10 EDT
Those are my favourite bugs, those that close by themselves :-) I admit i didn't
take the time to look at this. Feel free to reopen if you think there was still
something wrong on the NM-vpnc side.

Note You need to log in before you can comment on or make changes to this bug.