Bug 289021 - Mailgraph needs AddHandler cgi-script .cgi
Mailgraph needs AddHandler cgi-script .cgi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mailgraph (Show other bugs)
7
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 06:22 EDT by Patrick
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.14-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 19:35:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick 2007-09-13 06:22:50 EDT
Description of problem:
http://127.0.0.1/mailgraph will output the contents of mailgraph.cgi instead of
generating the html page because /etc/httpd/conf/httpd.conf has AddHandler
cgi-script .cgi commented out.

Version-Release number of selected component (if applicable):
1.12

How reproducible:
yum install mailgraph
firefox http://127.0.0.1/mailgraph

Steps to Reproduce:
1. yum install mailgraph
2. firefox http://127.0.0.1/mailgraph
3. 
  
Actual results:
Content of mailgraph.cgi is displayed

Expected results:
mailgraph.cgi generates the html page with pics and shows it

Additional info:
The solution is to enable AddHandler cgi-script .cgi and restart httpd
Comment 1 Patrick 2007-09-13 06:27:05 EDT
By the way, in the spec file the url for mailgraph is wrong. Currently it is
http://people.ee.ethz.ch/~dws/software/mailgraph
and should be changed to:
http://mailgraph.schweikert.ch/
Comment 2 Fedora Update System 2007-11-06 11:18:04 EST
mailgraph-1.14-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mailgraph'
Comment 3 Fedora Update System 2007-11-09 18:57:12 EST
mailgraph-1.14-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mailgraph'
Comment 4 Fedora Update System 2007-11-15 19:35:12 EST
mailgraph-1.14-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-11-15 19:42:25 EST
mailgraph-1.14-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.