Bug 28905 - Installer crashes when loading anaconda, used
Installer crashes when loading anaconda, used
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-22 14:30 EST by Nancy Kemper
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-20 07:23:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda fails during upgrade or installtion (952 bytes, text/plain)
2001-02-24 10:29 EST, nagaraj
no flags Details
Install Crash w/ Anaconda (998 bytes, text/plain)
2001-03-31 08:09 EST, rob alexander
no flags Details

  None (edit)
Description Nancy Kemper 2001-02-22 14:30:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; HP-UX B.10.20 9000/785)


"linux updates" with anaconda fix from your bug fix website and get the
same error: Process anaconda  install exited abnormally recevied signal 11;
also gave call trace c011f4c1 c012f5c0 c012a907 c012ab14 c012ac90 c01232c2
c0123507 c0107aac ; code 89 07 8b 4c 24 10 8b 09 89 4c 24 10 83 ee 01 73 b5
c7 01 00 

This is an HP machine with an Adaptec AHA-2940 AU -- SCSI adapter, TEAC
CD-516D
Loaded boot diskette and CD-Rom to start since this machine had SCO UNIX on
it before. Deleted the UNIX partiction before beginning.
(Needed to use boot diskette or it goes to SCO UNIX. So deleted UNIX
partition, then NO OS INSTALLED so using CDROM.)


Reproducible: Always
Steps to Reproduce:
1.Reboot machine with Red Hat BOOT DISKETTE
2.type "linux updates" at the boot prompt
3. Binary CD in the CD ROM drive
4. when prompted loaded the anaconda bug fix update-disk-20001009.img
5. crashes with error given in description
	

Actual Results:  crashes during Process anaconda  with error install exited
abnormally recevied signal 11; also gave call trace c011f4c1 c012f5c0
c012a907 c012ab14 c012ac90 c01232c2 c0123507 c0107aac ; code 89 07 8b 4c 24
10 8b 09 89 4c 24 10 83 ee 01 73 b5 c7 01 00 


Expected Results:  Install RED HAT 7.0
Comment 1 Michael Fulbright 2001-02-23 11:43:48 EST
This sounds like a kernel oops...
Comment 2 nagaraj 2001-02-24 10:29:15 EST
Created attachment 10944 [details]
anaconda fails during upgrade or installtion
Comment 3 rob alexander 2001-03-31 08:09:02 EST
Created attachment 14343 [details]
Install Crash w/ Anaconda
Comment 4 Doug Ledford 2001-04-03 04:36:22 EDT
The anaconda traceback is likely just a side effect of the real problem.  If
there was a kernel oops on the system, then that's the information I need to be
able to diagnose this issue.  I also need to know what was happening at the time
of the oops (was the system trying to load any drivers, etc).
Comment 5 Joao M. S. Silva 2001-04-11 16:27:39 EDT
The crash happens when the installer is "Reading Package Information..."
Comment 6 Doug Ledford 2001-04-19 19:28:19 EDT
Can you get new floppy disks and remake the boot disk and the updates disks. 
The error you have sounds suspiciously like something is corrupted somewhere and
that usually happens because of bad disks (please note, I've personally had 4
bad disks in a row and not gotten a good disk until my fifth try in the past, so
please don't assume disks are good, always check them when in doubt).  The best
way to check a disk is to format it under DOS/Windows or linux and see if they
report any bad sectors.  If they report bad sectors during the format, then just
throw the disk away, it's useless.  If you are using linux machines and don't
have a DOS/Windows machine then use the command fdformat /dev/fd0H1440 and it
will either succeed with all good sectors or tell you there was a format
failure.
Comment 7 Joao M. S. Silva 2001-04-20 07:23:39 EDT
My CD-ROM drive (Creative 36x) crashed during the install and I bought a Samsung
52x. I also changed my Targa 14" monitor to a NEC 15". This time I booted from
the CD-ROM drive, with the first CD of the download version of RH7.0. If I
dont't start with "linux updates expert" the Anaconda crash still happens, but
if I do that it works. Even having started with "linux updates expert" I don't
have the choice of intalling in text mode, but it works fine in graphical mode.

I don't know if it was the new CD-ROM drive, the new monitor (with the other
monitor the install stalled when changing to graphical mode) or the boot from
CD-ROM, but now it works. Booting from the CD is different from booting with the
disk -- perhaps the disk was damaged as you said.
Comment 8 Doug Ledford 2001-04-20 09:51:02 EDT
Good enough, I'll close this bug out then as NOTABUG and assume there was
something flaky in the hardware setup of the machine prior to the changes.

Note You need to log in before you can comment on or make changes to this bug.