Bug 28946 - installation dies in Anaconda
installation dies in Anaconda
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-22 17:51 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-27 18:37:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-22 17:51:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (WinNT; U)

After the installation loads RPMs it dies in Anaconda.  There is no option to provide a way to load the file
it apparently cannot find.

Reproducible: Always
Steps to Reproduce:
1.Install onto this system from CD's made from ISO image.

Actual Results:  First I tried to upgrade and the E#(&$#(&$ installation program was too stupid to ask "can I put RPMs
on one of these other 30 Gb of free disk space", it insisted they go onto / which was only 900Mb and
very full.  So I wiped the disk and tried to do a clean install.  But on several attempts it failed
with the message indicated in the URL.

Expected Results:  Uh, a complete install, right?

Intel dual processor motherboard with two PII 400 installed.  IDE CDROM.  Symbios U2W SCSI controller
5 Quantum U2W 9.1 Gb drives.  Matrox millenium graphics. 

Please email me if this is received (it never asked for my name.)

David Mathog

Comment 1 Michael Fulbright 2001-02-23 12:03:15 EST
What is the error you get when the new install failed?
Comment 2 Need Real Name 2001-02-23 12:56:53 EST
It said that there was an error in anaconda and then put up
the message available at:


that's also what it did on an upgrade attempt.  It would have been
nice if instead of dropping dead it provided some way to locate
the files it could not find.

I don't know if this is at all related, but somewhere during the
upgrade/installation attempts a disk failed (/dev/sdb1).  It may have
been dead before I even started - it was a disk I wasn't currently using.
It had been mounted for about 6 months, but no activity on it.
There's nothing on this disk at all and no particular reason that the
installation should even touch it.  After I realized that I used an
emergency boot disk to modify /etc/fstab on the existing root file system
(/dev/sda1) to comment out the line about /dev/sdb1, and it didn't
help - same error.  /dev/sdb1 isn't totally dead as fsck runs on it
up to a point, but then gives messages which suggest bad blocks.
Comment 3 Michael Fulbright 2001-02-25 11:33:30 EST
This error indicated that the CD you were installing from is missing essential
files.  Could you look on VC3 and VC4 (cntl-alt-f3 and -f4) and see if you are
getting read errors reported by the kernel.

Most likely the CD is bad or the CD drive in the system you are installing
cannot read this media type.
Comment 4 Michael Fulbright 2001-04-02 16:01:09 EDT
Closing due to inactivity - please reopen if you have anything to add to the bug

Note You need to log in before you can comment on or make changes to this bug.