Bug 28948 - [IDE-DMA] Install can't read from compaq CRD-8241B Atapi cd/dvd drive
[IDE-DMA] Install can't read from compaq CRD-8241B Atapi cd/dvd drive
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-22 18:57 EST by Steve Dum
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 14:41:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dum 2001-02-22 18:57:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.51 [en] (X11; I; Linux 2.2.5-15smp i686)


Trying to load fisher on a compaq 5100 workstation with CRD-8241B DVD drive
fails.  Bios reads CD1 and boots off it, loads up kernel, etc. and prompts
for language and keyboard.  Then can no longer read cd and you get stuck in
dialog box asking if you are loading from the cd - which it can't read.

console 4 window contains the messages (after removing and inserting the
cd)
disk change detected on device ide0(3,0)
<4> Interleaved files not (yet) supported
File unit size != 0 for ISO file (59392)

Guinness boots off the CD (and reads it) just fine.


Reproducible: Always
Steps to Reproduce:
1.insert cd1, boot system
2.click next twice	
3. select cd click ok
	

Actual Results:  can't read cd

Expected Results:  install OS
Comment 1 Glen Foster 2001-02-23 16:55:43 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Michael K. Johnson 2001-02-23 17:47:28 EST
By "Guinness boots off the CD (and reads it) just fine" I assume that
you mean that Guinness boots off that *drive* and reads from it just
fine, since you can't boot Guinness off the fisher CD.  Given that
assumption, this does sound typical of badly burned media.  Can you
try md5summing the media and comparing to the iso image?
Comment 3 Steve Dum 2001-02-26 12:16:34 EST
The comment about guinness were intended to say, that the 7.0 cd boots ok and
after booting it
can read the cd to procede with the load.

I do not believe that this is a cd reproduction problem.  The same CD set has
been used to load 2 other machines.  

Now, with the release of wolverine, I have the following data to add.
The wolverine cd's have the same behavior as fisher.  The cd bootstrap works,
but after prompting 
for language info, it can't read the cd drive.  I assume that the 2.4 kernel and
cd driver
have a problem with this hardware.   Also,  If I boot up NT on this box it has
no problem reading the
CD's.
Comment 4 Arjan van de Ven 2001-03-01 04:29:31 EST
Most likely IDE DMA related. Ivestigating
Comment 5 Arjan van de Ven 2001-03-09 06:04:20 EST
Can you give the _exact_ output of
cat /proc/ide/hdX/model 
(X = a b c or d, the one where your CDrom drive is on?)
Doesn't have to be 7.1beta, can be done in 7.0
Comment 6 Steve Dum 2001-03-09 13:04:29 EST
booting the 7.0 installer,  cat /proc/ide/hda/model results in
Compaq CRD-8241B
This is device hda because the hard drives are scsi.  Does that confuse  7.1
anaconda?
Comment 7 Arjan van de Ven 2001-03-09 13:14:40 EST
anaconda handles this just fine
Comment 8 Michael K. Johnson 2001-03-09 14:41:05 EST
This drive has been added to the dma blacklist, and all kernel builds
2.4.2-0.1.25 or later should have this, so when such a kernel shows
up in rawhide (we expect in the next few days), it should be testable.

Note You need to log in before you can comment on or make changes to this bug.