Bug 28954 - Files are timestamped in UTC
Summary: Files are timestamped in UTC
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: timeconfig   
(Show other bugs)
Version: 6.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 03:54 UTC by Ernie Martinez
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 23:17:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ernie Martinez 2001-02-23 03:54:55 UTC
If I create a file its timestamped in UTC, I've tried using timeconfig,, 
hwclock --localtime, I've copied the appropriate zone file 
to /etc/localtime (EST) linuxconf, and no matter what I try I still get 
timestamps 4 hours in the future. If I do a hwclock --show or type date it 
display the correct time.

This is causing a strange problem with Apache/Jserv/JSP where if you touch 
a .jsp file the webserver throws a "File not found" error, when trying to 
access the jsp file.

Thanks
Ernie

Comment 1 Ernie Martinez 2001-02-23 21:16:41 UTC
Today we just started experiencing this same problem on another machine. No 
changes were made to the OS. We're running on Dell 2U rack mount machines 
runing dual Pentium 700's. This is very odd!

Ernie

Comment 2 Michael K. Johnson 2001-02-27 23:21:15 UTC
Files are always timestamped in utc, the only question is how that is
displayed to the user.  This doesn't sound like a bug in the kernel.
Maybe in timeconfig if it isn't fixing the appearance for you.

Comment 3 Trond Eivind Glomsrxd 2001-02-27 23:27:33 UTC
What does running timeconfig indicate? The most solid way to run things is with
GMT in the PC bios, and tell that to timeconfig...

Other than that, I can't reproduce your problem and have never experienced it
myself.

Comment 4 Trond Eivind Glomsrxd 2001-03-22 22:36:53 UTC
Closing as "worksforme", due to lack of feedback.


Note You need to log in before you can comment on or make changes to this bug.