Bug 289591 - Unable to add workstation to samba domain
Summary: Unable to add workstation to samba domain
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-13 17:52 UTC by Zaphod Beeblebrox
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 20:48:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zaphod Beeblebrox 2007-09-13 17:52:28 UTC
Description of problem:
I get the following when doing a "net join" to add a new FC7 machine to a samba
domain:

[2007/09/13 13:49:29, 0] utils/net_rpc_join.c:net_rpc_join_newstyle(304)
  error setting trust account password: NT code 0x1c010002
Unable to join domain SOUTHPARK.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Simo Sorce 2007-09-13 18:18:32 UTC
What samba version is running on the "Samba Domain" ?

Comment 2 Zaphod Beeblebrox 2007-09-13 18:27:07 UTC
samba-3.0.23a-1 on the domain controller and samba-3.0.26a-0 on the client

Comment 3 Simo Sorce 2007-09-13 19:09:19 UTC
what user are you using to do the join?
what does the PDC logs say ?

Comment 4 Zaphod Beeblebrox 2007-09-13 19:31:49 UTC
On client machine named tweak:
net join -U <userid here>

On PDC:
tweak.log:
Use of uninitialized value in string at /usr/lib/perl5/vendor_perl/5.8.6/smbldap
_tools.pm line 291.
Use of uninitialized value in string at /usr/lib/perl5/vendor_perl/5.8.6/smbldap
_tools.pm line 291.
[2007/09/13 15:30:07, 0] rpc_parse/parse_prs.c:prs_mem_get(559)
  prs_mem_get: reading data of size 2 would overrun buffer by 1 bytes.
[2007/09/13 15:30:07, 0] rpc_server/srv_samr.c:api_samr_set_userinfo(848)
  api_samr_set_userinfo: Unable to unmarshall SAMR_Q_SET_USERINFO.
[2007/09/13 15:30:07, 0] rpc_server/srv_pipe.c:api_rpcTNP(2287)
  api_rpcTNP: samr: SAMR_SET_USERINFO failed.

10.0.1.6.log:
[2007/09/13 15:30:00, 0] rpc_server/srv_netlog_nt.c:get_md4pw(242)
  get_md4pw: Workstation TWEAK$: no account in domain
[2007/09/13 15:30:00, 0] rpc_server/srv_netlog_nt.c:_net_auth_2(461)
  _net_auth2: failed to get machine password for account TWEAK$: NT_STATUS_ACCES
S_DENIED


Comment 5 Simo Sorce 2007-09-13 22:19:43 UTC
Looks like there is some problems with smbldap_tools on the PDC, can you
successfully join windows servers/clients to the domain ?

Comment 6 Zaphod Beeblebrox 2007-09-14 02:47:34 UTC
No, there is not a problem with smbldap_tools. I am able to join the domain just
fine with a Fedora Core 4 client running samba-3.0.23a-1.

Please see
http://lists-archives.org/samba/31956-winbind-3-0-25c-problem-joining-3-0-24-domain.html

Apparently this bug was introduced in samba 3.0.25? I was hoping it was fixed in
3.0.26, but apparently not.

Comment 7 Simo Sorce 2007-09-14 14:30:35 UTC
Seem a different problem, but during the 3.0.23 dev series we found a bug in the
server side code we fixed in later releases.
This is a server bug, but you see the effect on the client as the client has the
fix and the server not. I will investigate to see if the client fix has some
unwanted side effects, meanwhile a stop gap solution is to upgrade your PDC to a
post 3.0.24 release.

Comment 8 Zaphod Beeblebrox 2007-09-14 21:43:30 UTC
Thank you. I rebuilt the 3.0.26 rpm from Fedora 7 and installed it on the PDC
and everything works ok now. You might want to warn anyone post 3.0.24 that it
doesn't like a <=3.0.24 PDC. Looks like Fedora 7 was the first version to
include samba > 3.0.24. You are welcome to close this ticket now.

Comment 9 Simo Sorce 2007-11-23 20:48:34 UTC
I guess we can mark this as not a bug (not of this release) as it works using
recent releases.


Note You need to log in before you can comment on or make changes to this bug.