Bug 28964 - Mice with extra buttons not selectable in anaconda or mouseconfig
Summary: Mice with extra buttons not selectable in anaconda or mouseconfig
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 05:55 UTC by Arion Blishen
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-26 19:37:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arion Blishen 2001-02-23 05:55:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; 0.8)
Gecko/20010211


MS Intellimouce and other mice with more than the left, right, and scroll
wheel are and can't be setup (selected and setup) by anaconda or mouseconfig.

It does not seem to be hard to get them to work and they should be able to
work out of the box.

Reproducible: Always
Steps to Reproduce:
1.Use anaconda or moseconfig
2.
3.

Comment 1 Michael Fulbright 2001-02-23 17:05:04 UTC
One part of the problem is there is currently no support in the kernel for
probing the number of buttons/etc on a mouse.  This will hopefully be addressed
in the near future.

Are you also saying there is no way to manually configure this?

Comment 2 Arion Blishen 2001-02-23 18:11:03 UTC
It can be done manually but it would better way better if the Red Hat installer had an option for MS Intellimouse Explorer/Optical/.. and then have the 
installer edit the config files.

The following page has how it is done
http://www-sop.inria.fr/koala/colas/mouse-wheel-scroll/

also see IMWheel homepage at
http://jcatki.dhs.org/imwheel/

This will also make the scroll wheel work in Netscape 4.x

Comment 3 Michael Fulbright 2001-02-27 23:37:34 UTC
Will add to list of features to conside for future releases. We are feature
frozen at this point of the development cycle.

Comment 4 Jeremy Katz 2002-08-19 19:05:36 UTC
We have options for Intellimice and generic wheel mice now

Comment 5 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.