Bug 289721 - SELinux is preventing /usr/bin/totem-video-thumbnailer from loading /usr/lib/libFLAC.so.8.1.0 which requires text relocation.
SELinux is preventing /usr/bin/totem-video-thumbnailer from loading /usr/lib/...
Status: CLOSED DUPLICATE of bug 285961
Product: Fedora
Classification: Fedora
Component: flac (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 14:28 EDT by Jonathan Roberts
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 13:33:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Roberts 2007-09-13 14:28:43 EDT
Description of problem:

The above SELinux alert occurs everytime a new video is added.

Version-Release number of selected component (if applicable):


How reproducible:

Everytime


Steps to Reproduce:
1.SELinux enabled as in default install
2.Add new video files to desktop/open file browser window
3.Review SELinux alert
  
Actual results:


Expected results:

Much too invasive and annoying for everyday use - is this really that big a
sercurity threat?

Additional info:
Comment 1 Daniel Walsh 2007-09-14 11:32:35 EDT
Have you  done what the setroubleshoot app has suggested?  Have you contacted
the destributer of /usr/lib/libFLAC.so.8.1.0  to tell them they have a problem
in the way they build their shared library?

chcon -t textrel_shlib_t /usr/lib/libFLAC.so.8.1.0 
Should stop SELinux from complaining.  But getting the vendor to fix the library
is the best long term solution.

You can also tell setroubleshoot to ignore the error, if it does not seem to
cause a problem.
Comment 2 Daniel Walsh 2007-09-18 13:21:11 EDT
libFLAC should not require this.  Reassigning to flac to be fixed.
Comment 3 Bastien Nocera 2007-09-18 13:33:52 EDT
As there's no version number, I'll guess this is an old libflac.

*** This bug has been marked as a duplicate of 285961 ***

Note You need to log in before you can comment on or make changes to this bug.