Bug 289831 - Sound doesn't work. GStreamer's fault?
Sound doesn't work. GStreamer's fault?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-09-13 15:13 EDT by Zack Cerza
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 12:29:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Gstreamer error (306.16 KB, image/png)
2007-09-19 03:07 EDT, Elvin E. Ebora
no flags Details

  None (edit)
Description Zack Cerza 2007-09-13 15:13:53 EDT
Description of problem:
The sound check in firstboot worked. It doesn't work in GNOME.

This is a Thinkpad Z61t laptop.
http://smolt.fedoraproject.org/show?UUID=022c3fe0-053a-4e67-bfba-bb007a7f09b0

From ~/.xsession-errors:
sound-properties-Message: Error running pipeline 'audiotestsrc wave=sine
freq=512 ! audioconvert ! audioresample ! gconfaudiosink': Internal GStreamer
error: state change failed.  Please file a bug at
http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer.
[gstswitchsink.c(155): gst_switch_commit_new_kid (): /pipeline0/gconfaudiosink0:


Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.11.svn20070907.fc8
gstreamer-0.10.14-3.fc8
Comment 1 Elvin E. Ebora 2007-09-19 03:07:26 EDT
Created attachment 199321 [details]
Gstreamer error
Comment 2 Elvin E. Ebora 2007-09-19 03:11:01 EDT
Same problem with me using IBM Thinkpad T43 laptop. Sometimes after I reboot,
the sound works but most often the sound is not working at all and I'm having
the error as shown on my attachment.

gstreamer-plugins-base-0.10.14-5.fc8
gstreamer-0.10.14-3.fc8
gstreamer-tools-0.10.14-3.fc8
gstreamer-plugins-good-0.10.6-5.fc8

Linux localhost.localdomain 2.6.23-0.185.rc6.git7.fc8 #1 SMP Mon Sep 17 18:14:46
EDT 2007 i686 i686 i386 GNU/Linux
Comment 3 Zack Cerza 2007-09-19 13:06:31 EDT
Basically, until I kill -9 pulseaudio and restart it, I've got no sound at all.
Comment 4 Elvin E. Ebora 2007-09-19 21:56:37 EDT
I tried what Zack did (killed pulseaudio and restart it) and the sound works.
Comment 5 Lennart Poettering 2007-09-23 20:42:16 EDT
Do you have install gstreamer-plugins-pulseaudio?

Could you please check whether "pacat /dev/urandom" works and produces some
white noise on your boxes?
Comment 6 Lennart Poettering 2007-09-23 20:42:58 EDT
s/install/installed/

sorry, it's getting late here aorund ;-)
Comment 7 Zack Cerza 2007-09-24 15:40:22 EDT
yum is telling me gstreamer-plugins-pulseaudio doesn't exist.
Comment 8 Elvin E. Ebora 2007-09-24 23:40:01 EDT
The updates last Friday (September 21) fixed my sound problems. The sound is now
working properly. I have the following components installed:

gstreamer-plugins-base-0.10.14-5.fc8
gstreamer-0.10.14-3.fc8
gstreamer-tools-0.10.14-3.fc8
gstreamer-plugins-good-0.10.6-5.fc8

pulseaudio-lib-0.9.7-0.11.svn20070907.fc8
pulseaudio-esound-compat-0.9.7-0.11.svn20070907.fc8
pulseaudio-0.9.7-0.11.svn20070907.fc8
akode-pulseaudio-2.0.1-8.fc8

Comment 9 Lennart Poettering 2007-09-25 09:17:34 EDT
(In reply to comment #7)
> yum is telling me gstreamer-plugins-pulseaudio doesn't exist.

Sorry, the name is gstreamer-plugins-pulse
Comment 10 Zack Cerza 2007-09-27 12:29:34 EDT
Yes, I have it installed. And I haven't seen the problem in this report
recently, so I'll close it for now.

Both 'Test' buttons in the 'Audio Conferencing' section of
gnome-sound-properties are doing very, very scary things. I'll file a new bug
about that.
Comment 11 Zack Cerza 2007-09-27 12:34:17 EDT
The "scary things" may have been a false alarm...

Note You need to log in before you can comment on or make changes to this bug.