Bug 290001 - Enabling Desktop Effects causes title bar to disappear
Enabling Desktop Effects causes title bar to disappear
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-13 16:47 EDT by Jake
Modified: 2010-06-01 06:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 02:15:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
smoltSendProfile (5.73 KB, text/plain)
2007-09-13 16:47 EDT, Jake
no flags Details

  None (edit)
Description Jake 2007-09-13 16:47:16 EDT
Description of problem:
When going to System > Preferences > Look & Feel > Desktop effects and enabling
the desktop effects, all new windows are created in the upper left corner of the
screen without the title bar to move them. When hitting Alt + Space and
selecting move, the windows does not move with the keyboard or the mouse. I'm
not sure if this is related to my hardware, but I think it worked in f8test1.

Version-Release number of selected component (if applicable):
"Out of the box" installed from f8test2 Live CD

How reproducible:
On my installation, 100%

Steps to Reproduce:
1. Download
2. Boot from CD and select install to hard disk
3. After initial config, enable desktop effects
Additional info:
This is a fairly new Dell Laptop, a Latitude D630. The chipset in it may be part
of the problem as it may not be fully supported yet. But as mentioned above, I
think it worked on f8test1.

Attached is the listing from smoltSendProfile
Comment 1 Jake 2007-09-13 16:47:16 EDT
Created attachment 195231 [details]
Comment 2 Adam Jackson 2007-09-27 16:26:14 EDT
compiz bug
Comment 3 Jake 2007-10-08 14:19:36 EDT
This seems to be working in test3.
Comment 4 Adam Huffman 2007-11-12 06:30:58 EST
This bug is still there for me in F8 released.
Comment 5 David Juran 2007-11-13 04:15:33 EST
Do you have any gconf settings lingering from the old F7 compiz? I've noticed
that clearing them out helps.
Comment 6 Adam Huffman 2007-11-13 04:27:56 EST
Yes, I think you're right.  I cleared the old settings out and it's working now.
Comment 7 Matěj Cepl 2007-12-19 11:22:46 EST
OK, so the problem is not sanitizing previous settings on upgrade, right?
Kristian, this is for you.
Comment 8 Oded Arbel 2007-12-30 12:20:03 EST
This looks like a duplicate of bug #245495
Comment 9 Matěj Cepl 2008-01-10 11:35:30 EST
Do you have place plugin in /apps/compiz/general/allscreens/options/active_plugins


gconftool-2 --get /apps/compiz/general/allscreens/options/active_plugins

to find out. If not, try to add it there with gconf-editor (I don't know how to
manage lists with gconftool-2).

Does it help?

Comment 10 Jake 2008-01-10 14:17:02 EST
I only saw this on F8 Test 2. In F8 final desktop effects are working great. In
comment 4 Adam Huffman said he saw the issue in F8 final but that clearing out
old settings from F7 fixed it.
Comment 11 Bug Zapper 2008-11-26 02:47:49 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 12 Bug Zapper 2009-01-09 02:15:21 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.