This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 2901 - PCMCIA install fails on Tosh Tecra 780DVD w/ 3c589C
PCMCIA install fails on Tosh Tecra 780DVD w/ 3c589C
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-17 22:23 EDT by dave
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:43:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dave 1999-05-17 22:23:17 EDT
Hi.  Installing 6.0 fails to detect my 3c589 PCMCIA ethernet
card during install.

It initializes the card, and the green light on the network
connector turns green, but prints:

insmod /tmp/pcmcia/lib/modules/preferred/3c589_cs.o
RequestIRQ: Resource already in use
get dev info on socket 1 failed: Resource temporarily
unavailable.

I've tried configuring the card services for both CardBus
and PCIC, both of which failed.  The laptop has the latest
BIOS version.

Thanks,
Dave Wreski
dave@nic.com
Comment 1 jmoses 1999-05-18 16:05:59 EDT
We've seen this one before on some inhouse machines.

The Tecra 780DVD seems to have a little difficulty parting with
already-used interrupts. Make sure /etc/sysconfig/pcmcia PCIC_OPTS
has "pci_csc=1", and that you are _not_ excluding IRQ 3 in
/etc/pcmcia/config.opts. Alternately, it is okay to define an
irq_list in PCIC_OPTS.

The reason seems to be that the revision of the PCMCIA chipset is
slightly incompatible with earlier versions, and is thus slightly
incompatible with pcmcia_cs. The 780 uses the ToPIC 97, but it seems
to differ from the one in the 750. You're lucky, though: the Tecra
7000's PCMCIA doesn't work for me at all.

Note You need to log in before you can comment on or make changes to this bug.