Bug 290111 - setroubleshoot: wrong command suggested (no path)
setroubleshoot: wrong command suggested (no path)
Status: CLOSED DUPLICATE of bug 244345
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-13 17:42 EDT by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-15 14:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-09-13 17:42:50 EDT
The suggestion to run "chcon -t unconfined_execmem_exec_t X" is wrong. The final
part should contain the full path to the program.
Comment 1 John Dennis 2007-09-15 14:29:50 EDT
I'm going to close this as a dup of bug  244345. There are two issues at play
here. Sometimes the audit system does not return the full path. This is getting
better with new versions of the kernel and audit. Since setroubleshoot relies
exclusively on audit data we're somewhat at the mercy of what kernel/audit
returns. The second issue is that setroubleshoot attempts to compensate for
incomplete information and tries to intuit the path information from other data.

We're in the process of modifying setroubleshoot to not try and intuit the path
information, instead if it's available it will be used, otherwise it will
clearly indicate the information was absent, and not give partial information.

*** This bug has been marked as a duplicate of 244345 ***

Note You need to log in before you can comment on or make changes to this bug.