Bug 290161 - Audio doesn't work - 82801H (ICH8 Family) HD Audio Controller (rev 02)
Audio doesn't work - 82801H (ICH8 Family) HD Audio Controller (rev 02)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 18:07 EDT by Andrew Parker
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 09:49:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsconfig.log as requested by system-config-soundcard (55.39 KB, text/plain)
2007-09-13 18:07 EDT, Andrew Parker
no flags Details
scsrunlog as requested by system-config-soundcard (261 bytes, text/plain)
2007-09-13 18:10 EDT, Andrew Parker
no flags Details
Output of amixer in Fedora (1.57 KB, text/plain)
2007-09-19 18:20 EDT, Andrew Parker
no flags Details
Output of amixer in Ubuntu (1.63 KB, application/octet-stream)
2007-09-19 18:20 EDT, Andrew Parker
no flags Details
scsconfig (59.70 KB, text/plain)
2007-09-22 20:32 EDT, Ole Tøsse Kolvik
no flags Details

  None (edit)
Description Andrew Parker 2007-09-13 18:07:41 EDT
Description of problem:

Soundcard detected, but does not play audio

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)

Version-Release number of selected component (if applicable):

system-config-soundcard-2.0.6-8.fc8

How reproducible:

Always

Steps to Reproduce:
1.  Run test in system-config-soundcard
2.
3.
  
Actual results:

No audio


Expected results:


Additional info:
Comment 1 Andrew Parker 2007-09-13 18:07:41 EDT
Created attachment 195291 [details]
scsconfig.log as requested by system-config-soundcard
Comment 2 Andrew Parker 2007-09-13 18:10:02 EDT
Created attachment 195301 [details]
scsrunlog as requested by system-config-soundcard
Comment 3 Martin Stransky 2007-09-19 08:57:58 EDT
Your soundcard looks used by some other application. Cau you boot to runlevel 3
(w/o X window) and try to run aplay on console? (how-to is here
http://people.redhat.com/stransky/alsa/)
Comment 4 Andrew Parker 2007-09-19 18:19:28 EDT
ok, tried that but same results.

However, I plugged some headphones in, and sound comes out of that.  I didn't
try this before, but I assume it work then too.

No sound from the speakers has got me baffled.  I tried fiddling with everything
I could in alsamixer and kmix, but no joy.  Any suggestions?

I also have Ubuntu on the laptop, and the speakers work ok with that.  I ran
amixer on this and Fedora to see if any differences in the settings jump out
but... no joy (too many differences for me to work it out).  I'll attach them,
in case there's anything that you could comment on.

Thanks
Andy

Comment 5 Andrew Parker 2007-09-19 18:20:04 EDT
Created attachment 200221 [details]
Output of amixer in Fedora
Comment 6 Andrew Parker 2007-09-19 18:20:28 EDT
Created attachment 200231 [details]
Output of amixer in Ubuntu
Comment 7 Ole Tøsse Kolvik 2007-09-22 20:29:38 EDT
I have exactly the same problem.
Comment 8 Ole Tøsse Kolvik 2007-09-22 20:32:31 EDT
Created attachment 203281 [details]
scsconfig
Comment 9 Martin Stransky 2007-09-27 09:49:14 EDT
(In reply to comment #4)
> However, I plugged some headphones in, and sound comes out of that.  I didn't
> try this before, but I assume it work then too.

That's a kernel/alsa-driver problem. It should initialize output of your sound
device by default. Please report it to ALSA project (www.alsa-project.org).
Comment 10 Andrew Parker 2007-09-27 13:22:21 EDT
Thanks.  

Looks like Jesse has already done this:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=3394

Note You need to log in before you can comment on or make changes to this bug.