Bug 29026 - Matrox DRI is disabled?
Matrox DRI is disabled?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 09:10 EST by Hetz
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 09:10:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hetz 2001-02-23 09:10:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)


Seems according to the SRPM of XFree86 4.0.2-9 in the wolverine beta, that
Matrox DRI has been disabled

Reproducible: Always
Steps to Reproduce:
1.Grab the SRPM
2.goto /usr/src/redhat/SPEC
3.vi XFree86.spec

:)
	

Actual Results:  No DRI for Matrox

According to the changelog of the SRPM in the wolverine beta, the Matrox
DRI is disabled "because it's broken".
Well, it IS broken on post version of the official XFree 4.0.2 version, and
the DRI team are working on it to fix it and the fix will only appear on
XFree 4.0.3.

Could someone PLEASE put the DRI from the official XFree 4.0.2 back please?
otherwise, Redhat 7.1 will be totally unusable for Matrox users who wants
to use 3D on their X windows (and Matrox got big part of the Linux
developers and users)

Thanks,
Hetz
Comment 1 Bill Nottingham 2001-02-23 12:26:32 EST
It's enabled in more recent builds (0.9.2); it won't be configured
by default, though.
Comment 2 Hetz 2001-02-23 17:25:57 EST
Umm.. what do you mean for those things:

1. build 0.9.2??? what version is that? the build of Redhat 7.1 beta's? the 
number is not cleared to me..

2. By meaning of "it won't be configured by the default" - do you mean with 
Xconfigurator?

3. Where can I get this "build 0.9.2" (which I totally don't understand what 
is it)

Hetz

Comment 3 Mike A. Harris 2001-02-24 06:15:50 EST
Please relax guys.  Matrox DRI was disabled because it was totally broken,
and I'd rather ship NO DRI driver than ship one that is broken and receive
500 bug reports all duplicates.  In the mean time, I have decided to disable
DRI via Xconfigurator so that those that want to turn it on just to see that
yes, it is broken, will have the luxury of doing so.  ;o)

XFree86 4.0.3 is not out yet, and does *NOT* currently have a fix for this
bug in it.  Our 4.0.2 package contains all of the current code in what will
become 4.0.3.  If 4.0.3 is out soon, I will update the RPM to it before next
release, if not then I'll be shipping 4.0.2 + everything currently going into
4.0.3 - which currently doesn't include working DRI on Matrox.

Also, there is no XFree86-4.0.2-0.9.2, rather it is -9.1.25, and is a test
version.  Bill made a typo.  I am working with Matrox to try and resolve these
issues ASAP, but there is no working driver currently.  Nonetheless, your
request is honored in my latest build.  Hopefully we can squash this nasty
soon though so DRI is working on these cards.

Take care.

Note You need to log in before you can comment on or make changes to this bug.