Bug 290351 - freenx-0.7.0-1.fc7 on server fails, reports kde-config commnad not found
freenx-0.7.0-1.fc7 on server fails, reports kde-config commnad not found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 21:20 EDT by Eric Smith
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.7.0-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 17:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Smith 2007-09-13 21:20:48 EDT
Description of problem:

After updating server to freenx-0.7.0-1.fc7, all attempts to connect from client
get an error "/usr/libexec/nx/nxloadconfig: line 285: ked-config: command not
found".  This is despite the fact that my connect preferences are set to use
Gnome, not KDE.


Version-Release number of selected component (if applicable):

0.7.0-1.fc7
How reproducible:


Steps to Reproduce:
1.  Set up an F7 system to act as an nx server, verify nx access from client
2.  Update freenx package to 0.7.0-1.fc7
3.  Connect again with nx client
  
Actual results:

connection fails.  clicking "details" button on client shows:

NX> 203 NXSSH running with pid: 69444
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 64.62.206.10 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
/usr/libexec/nx/nxloadconfig: line 285: kde-config: command not found
HELLO NXSERVER - Version 1.5.0-70 OS (GPL)
NX> 105 Killed by signal 15.

No entries are added to the .nx directory on the server, even with debugging
turned on.

Expected results:

successful connection

Additional info:
Comment 1 Eric Smith 2007-09-13 21:28:33 EDT
I just confirmed that removing freenx-0.7.0-1.fc7 and installing
freenx-0.6.0-12.fc7 fixes the problem.
Comment 2 Jon Ciesla 2007-09-13 21:34:19 EDT
Can you post your client connection config file?  I can connect with both Gnome
and KDE.  What client/version are you using, and on what OS?  I'm using
WinXP-SP2/NoMachine 3.0.0-78, with Fedora 7 on the server running
freenx-0.7.0-1.fc7.  32 bit or 64 bit?
Comment 3 Jack Tanner 2007-09-15 18:28:30 EDT
I'm seeing the same thing. Fedora 7, nx-2.1.0-22.fc7, freenx-0.7.0-1.fc7, 32bit.

Now, more interestingly, any connection to nxserver produces the same error message:

# /usr/libexec/nx/nxserver --list
/usr/libexec/nx/nxloadconfig: line 285: kde-config: command not found
NX> 100 NXSERVER - Version 1.5.0-70 OS (GPL)
NX> 127 Sessions list:

Display Username        Remote IP       Session ID
------- --------------- --------------- --------------------------------
NX> 999 Bye

I'll keep investigating and post if anything comes up.
Comment 4 Jack Tanner 2007-09-15 18:56:35 EDT
Workaround: yum install kdelibs, which provides kde-config. This lets me log in
to my Gnome desktop, and also removes the error message from nxserver --list.
Comment 5 Eric Smith 2007-09-15 21:15:25 EDT
Thanks for the workaround.  I'll use it for now, but I hope that the problem can
be fixed, as installing kdelibs pulls in 19 other RPMs I didn't otherwise need.

At the very least, if the problem isn't fixed, freenx needs to declare kdelibs
as a dependency, but IMHO that's a suboptimal solution.

I'd previously tried doing a "yum search kde-config", but that didn't find any
packages.
Comment 6 Jack Tanner 2007-09-16 13:04:28 EDT
Eric, the yum command that answers that question is "yum whatprovides
/usr/bin/kde-config".

This has got to be a freenx bug. If you look at nxloadconfig line 285, it's
trying to set KDE_PRINTRC via the kde-config invocation. But in
/etc/nxserver/node.conf, I've explicitly set ENABLE_KDE_CUPS=0, so it shouldn't
try, it seems.

I've reported this to the freenx mailing list. See
http://thread.gmane.org/gmane.network.freenx.general/5843
Comment 7 Eric Smith 2007-09-16 14:17:35 EDT
Except that I had no idea what directory it would be in.  I suppose I could have
guessed that it might be /usr/bin, but for all I knew it might have been any
directory that might have been in the path, or that freenx might have added to
its path.

Even if ENABLE_KDE_CUPS=1, it should still deal gracefully with the absence of
kde-config.  It's easy enough to do that in scripts.

Comment 8 Jan Andrejkovic 2007-09-22 15:47:26 EDT
Hello,

I had the same problem and I do not use KDE either so I did not want to install
KDE libraries.

I tried to comment whole line 285 in /usr/libexec/nx/nxloadconfig and it works
fine now:

#[ -z "$KDE_PRINTRC" ] && KDE_PRINTRC=$(kde-config
--localprefix)"/share/config/kdeprintrc"

So this workaround is for those who do not use KDE. I did  not investigate this
bug into big details but whole line 285 seems to be KDE related so commenting it
should not make any difference for non-KDE users.

Jan
Comment 9 Ville Skyttä 2007-09-22 16:37:25 EDT
Axel is not on duty at the moment, I'm watching his packages meanwhile.  I don't
have a clue about freenx, but looks like this is easy enough to fix.

However, I don't see nxloadconfig being called so that a failing command would
abort its execution, so I'm wondering why is it that this causes failures.  Does
something not cope with the stderr output if kde-config is not available?

Could someone who has run into the failures test if replacing "$(kde-config
--localprefix)" in nxloadconfig with "$(kde-config --localprefix 2>/dev/null)"
fixes it?  If not, does "$(kde-config --localprefix || : )"?  (IOW, if it's the
exit status or stderr spewage that breaks things.)
Comment 10 Jan Andrejkovic 2007-09-22 20:32:54 EDT
Hello Ville,

Uncommenting the line 285 and replacing "$(kde-config
--localprefix)" with "$(kde-config --localprefix 2>/dev/null)" helped as well.

I tried to remove 2>/dev/null and error was displayed again, so I'm positive
your fix works fine.

By the way you can see the bug also just by executing nxloadconfig from command
line (if you do not use KDE or do not have KDE libs installed):

[machine]# /usr/libexec/nx/nxloadconfig
/usr/libexec/nx/nxloadconfig: line 285: kde-config: command not found

Jan
Comment 11 Ville Skyttä 2007-09-23 04:54:29 EDT
Yes, it's easy enough to see where the error message comes from, but grasping
why it's not just a harmless error message but actually causes failures requires
better understanding of how nx/freenx works than I have.

Anyway, 0.7.0-2 which will land in updates-testing soon should both avoid
bothering with setting up KDE_PRINTRC altogether if ENABLE_KDE_CUPS is not 1,
and not cause these failures if it is 1 but kde-config is not available or fails
for some other reason.  Please test it and report back here or in bodhi after
you see the comment about it being available in updates-testing.
Comment 12 Fedora Update System 2007-09-25 04:26:52 EDT
freenx-0.7.0-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2007-10-03 17:16:10 EDT
freenx-0.7.0-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.