Bug 290361 - Anaconda crashes if existing logical volumes have '-' in their names
Summary: Anaconda crashes if existing logical volumes have '-' in their names
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-14 02:35 UTC by Michel Alexandre Salim
Modified: 2008-04-28 10:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-28 10:10:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash log after root-on-LVM attempt (23.76 KB, text/plain)
2007-09-14 02:35 UTC, Michel Alexandre Salim
no flags Details
Crash log after /boot on primary, root on LVM (29.08 KB, text/plain)
2007-09-14 02:36 UTC, Michel Alexandre Salim
no flags Details

Description Michel Alexandre Salim 2007-09-14 02:35:33 UTC
Description of problem:
Installing from the live x86_64 image, I encountered the following Anaconda bugs:

- If all partitions declared were on LVM, Anaconda crashes as soon as I hit Next
- If I put /boot on a primary partition, Anaconda crashes soon after the
timezone selection dialog (as soon as it has to write to disk)

I have turned off all swap devices (verified by running top)

Version-Release number of selected component (if applicable):
anaconda-11.3.0.28-1

How reproducible:
Always

Steps to Reproduce:
1. Install to Hard Drive, custom partition, define only root on LVM
2. Install to Hard Drive, custom partition, /boot on primary, root on LVM
  
Actual results:
Both failed. See attached traces

Expected results:
First case should produce a warning, second case should work

Additional info:
Swap is off. Disk partitioned by openSUSE's installer. Installation attempted on
a Thinkpad T61 (Core 2 Duo)

Comment 1 Michel Alexandre Salim 2007-09-14 02:35:33 UTC
Created attachment 195441 [details]
Crash log after root-on-LVM attempt

Comment 2 Michel Alexandre Salim 2007-09-14 02:36:30 UTC
Created attachment 195451 [details]
Crash log after /boot on primary, root on LVM

Comment 3 Michel Alexandre Salim 2007-09-15 23:44:49 UTC
As it turns out, Fedora's Anaconda (or parted) does not allow logical volume
names that contain dashes, which is allowed by openSUSE. Downgrading this to an
enhancement request: properly handle existing LV names

Comment 4 Robin Bowes 2007-09-17 23:19:33 UTC
Hmmm, I had a similar problem without dashes in lv names.

My lv names are lv_root, lv_usr, etc.

Comment 5 Michel Alexandre Salim 2007-09-17 23:51:34 UTC
So basically, the sanity checks that are run when the user attempts to create a
new LV should also be carried out on the existing LVs -- the current assumption,
I think, is that all the LVs are created through Red Hat/Fedora tools and thus
follow the same naming constraints.

Comment 6 Joel Andres Granados 2008-04-28 10:10:35 UTC
This is better in rawhide.


Note You need to log in before you can comment on or make changes to this bug.