Bug 29046 - Cannot recompile qt - dlopen
Summary: Cannot recompile qt - dlopen
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 15:10 UTC by Sammy
Modified: 2016-11-24 15:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 21:25:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2001-02-23 15:10:19 UTC
I tried to rebuild qt-2.2.4-4 rpms from the source rpm and most
of the compilation goes through (libraries) but at some point it
crashes with message that it cannot find 4 function calls, one of
them being dlopen (I can't remember the others but they also started
with dl...). This is most likely a glibc problem  if not please
forward to the qt maintainer.

Comment 1 Jakub Jelinek 2001-02-23 15:19:05 UTC
Please can you provide that part of the buildlog where it show the error?
I was rebuilding the whole distribution yesterday (including qt-2.2.4-4)
and everything (but 4 completely different packages) built just fine.
If it cannot find dlopen, then it looks like it does not add -ldl during link
stage or something.

Comment 2 Sammy 2001-02-24 21:25:28 UTC
The part of log is below. I have:

gcc-2.96-75
gcc-c++-2.96-75
cpp-2.96-75
libstdc++-2.96-75
libstdc++-devel-2.96-75
glibc-2.2.2-3
glibc-common-2.2.2-3
glibc-devel-2.2.2-3                          
                                                                                                            
----------------------log-----------------------------
g++ -shared -Wl,-soname,libqutil.so.1 -L/usr/src/redhat/BUILD/qt-2.2.4/lib
-Wl,-rpath,/usr/src/redhat/BUILD/qt-2.2.4/lib   -o libqutil.so.1.0.0 qprocess.o
qprocess_unix.o moc_qprocess.o  -lqt  && mv libqutil.so.1.0.0
/usr/src/redhat/BUILD/qt-2.2.4/lib/; cd /usr/src/redhat/BUILD/qt-2.2.4/lib/ &&
rm -f libqutil.so libqutil.so.1 libqutil.so.1.0; ln -s libqutil.so.1.0.0
libqutil.so; ln -s libqutil.so.1.0.0 libqutil.so.1; ln -s libqutil.so.1.0.0
libqutil.so.1.0
make[5]: Leaving directory `/usr/src/redhat/BUILD/qt-2.2.4/tools/designer/util'
make[4]: Leaving directory `/usr/src/redhat/BUILD/qt-2.2.4/tools/designer'
make uic
make[4]: Entering directory `/usr/src/redhat/BUILD/qt-2.2.4/tools/designer'
if [ -d uic ]; then cd uic ; make; fi
make[5]: Entering directory `/usr/src/redhat/BUILD/qt-2.2.4/tools/designer/uic'
g++  -c -I/usr/src/redhat/BUILD/qt-2.2.4/include -pipe -O2 -march=i386
-mcpu=i686 -fno-exceptions -DUIC -I../shared -I../util
-I../../../src/3rdparty/zlib -o uic.o uic.cpp
g++  -c -I/usr/src/redhat/BUILD/qt-2.2.4/include -pipe -O2 -march=i386
-mcpu=i686 -fno-exceptions -DUIC -I../shared -I../util
-I../../../src/3rdparty/zlib -o ../shared/widgetdatabase.o
../shared/widgetdatabase.cpp
g++  -c -I/usr/src/redhat/BUILD/qt-2.2.4/include -pipe -O2 -march=i386
-mcpu=i686 -fno-exceptions -DUIC -I../shared -I../util
-I../../../src/3rdparty/zlib -o ../shared/domtool.o ../shared/domtool.cpp
g++  -c -I/usr/src/redhat/BUILD/qt-2.2.4/include -pipe -O2 -march=i386
-mcpu=i686 -fno-exceptions -DUIC -I../shared -I../util
-I../../../src/3rdparty/zlib -o ../integration/kdevelop/kdewidgets.o
../integration/kdevelop/kdewidgets.cpp
g++ -L/usr/src/redhat/BUILD/qt-2.2.4/lib
-Wl,-rpath,/usr/src/redhat/BUILD/qt-2.2.4/lib   -o
/usr/src/redhat/BUILD/qt-2.2.4/bin/uic uic.o ../shared/widgetdatabase.o
../shared/domtool.o ../integration/kdevelop/kdewidgets.o   -lqutil -L../lib
-lqt
/usr/src/redhat/BUILD/qt-2.2.4/lib/libqt.so: undefined reference to `dlerror'
/usr/src/redhat/BUILD/qt-2.2.4/lib/libqt.so: undefined reference to `dlclose'
/usr/src/redhat/BUILD/qt-2.2.4/lib/libqt.so: undefined reference to `dlopen'
/usr/src/redhat/BUILD/qt-2.2.4/lib/libqt.so: undefined reference to `dlsym'
collect2: ld returned 1 exit status
make[5]: *** [/usr/src/redhat/BUILD/qt-2.2.4/bin/uic] Error 1
make[5]: Leaving directory `/usr/src/redhat/BUILD/qt-2.2.4/tools/designer/uic'
make[4]: *** [uic] Error 2
make[4]: Leaving directory `/usr/src/redhat/BUILD/qt-2.2.4/tools/designer'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/usr/src/redhat/BUILD/qt-2.2.4/tools/designer'
make[2]: *** [designer] Error 2
make[2]: Leaving directory `/usr/src/redhat/BUILD/qt-2.2.4/tools'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/qt-2.2.4/tools'
make: *** [sub-tools] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.29190 (%build)
 
 
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.29190 (%build)

Comment 3 Jakub Jelinek 2001-03-08 13:19:49 UTC
Really cannot reproduce.

Comment 4 Michal Widera 2004-12-12 17:19:18 UTC
Same error apear when i have trying to build generic example program
from
http://libdbi.sourceforge.net/docs/programmers-guide/quickstart-code.html

cc genric.c -I/usr/include/dbi -ldbi -L/usr/lib
/usr/lib/libdbi.so: undefined reference to `dlerror'
/usr/lib/libdbi.so: undefined reference to `dlclose'
/usr/lib/libdbi.so: undefined reference to `dlopen'
/usr/lib/libdbi.so: undefined reference to `dlsym'
collect2: ld returned 1 exit status
make: *** [genric] BÅÄd 1

Gretz,
Muro

Comment 5 Jakub Jelinek 2004-12-12 18:11:56 UTC
You need to add -ldl

Comment 6 Partha Aji 2007-02-18 06:24:13 UTC
*** Bug 229056 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.