Bug 2905 - lib/rpmrc.c uses FILENAME_MAX which is 14 on HPUX
lib/rpmrc.c uses FILENAME_MAX which is 14 on HPUX
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-18 04:59 EDT by benedict
Modified: 2015-01-07 18:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-18 10:12:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description benedict 1999-05-18 04:59:18 EDT
On HPUX 10.20 you will see the following:

$ rm
f234567890123456789012345678901234567890123456789012345678901234567890
$ touch
f234567890123456789012345678901234567890123456789012345678901234567890
$ rpm
--rcfile=f234567890123456789012345678901234567890123456789012345678901234567890
Unable to open f234567890123456 for reading: No such file or
directory.

This is due to the code in lib/rpmrc.c:548:

	char fn[FILENAME_MAX+1];

because /usr/include/stdio.h defines FILENAME_MAX to 14 !!
Comment 1 Jeff Johnson 1999-05-18 10:12:59 EDT
Fixed in rpm. Thanks for reporting.

Note You need to log in before you can comment on or make changes to this bug.