Bug 29051 - gnome xterm ignores --login
Summary: gnome xterm ignores --login
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pdksh (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 15:23 UTC by Marty Shannon
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 20:18:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marty Shannon 2001-02-23 15:23:22 UTC
After install, user has /bin/bash as login shell.  I change it to
/bin/ksh.  I change xterm preferences to "always use --login".  User's
.profile is not sourced by ksh on next login.

Comment 1 David Mason 2001-02-23 15:49:51 UTC
hp - I tried '$useradd -s /usr/bin/ksh test' after setting this in
gnome-terminal and it returned 'unable to lock password file' - however it does
dawn on me that you would need to log out of X after changing shells as X will
"hold on to" bash after the login. Is this the case or do we have a
gnome-terminal problem?

Comment 2 Marty Shannon 2001-02-23 16:04:23 UTC
Sorry, my bad.  I use text login, so X is completely exited.  Actually, I think
I rebooted somewhere along the way, too.  A possibility is that it is
ksh-related, but this worked fine in 6.2, for instance.

Comment 3 Preston Brown 2001-02-23 21:08:57 UTC
is this xterm or gnome-terminal?

Comment 4 Marty Shannon 2001-02-23 21:20:33 UTC
This is definitely gnome-terminal.

Comment 5 Glen Foster 2001-02-23 21:54:20 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 6 Havoc Pennington 2001-02-23 22:57:51 UTC
The problem as far as I can tell is that exec'ing ksh with a hyphen in front
("-/bin/ksh") does not result in a login shell, ksh is broken somehow.
The setting works with bash.

Comment 7 Trond Eivind Glomsrxd 2001-02-26 20:15:14 UTC
Exacly how does the exec call look?

Comment 8 Trond Eivind Glomsrxd 2001-02-26 20:18:19 UTC
HP: how does the call look?

It gives you a login shell if called with "-l" or if the program (argv[0])
starts with "-". These work.

Comment 9 Trond Eivind Glomsrxd 2001-02-26 22:45:44 UTC
Can't reproduce - when I set something in .profile and choose "login shell", I
get it.

Comment 10 Marty Shannon 2001-02-26 23:19:51 UTC
Will try the sequence again, taking more careful notes.  However, I must note
that on the machine in question, I still have to manually do ". ./.profile"
after opening a gnome-xterm.  If I can reproduce, I'll reopen the bug if I'm
permitted to (can I?).


Note You need to log in before you can comment on or make changes to this bug.