Bug 29067 - RFE docbook2* cannot use non-system backends
Summary: RFE docbook2* cannot use non-system backends
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 15:52 UTC by Ed Bailey
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 21:51:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed Bailey 2001-02-23 15:52:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22enterprise i686; en-US;
0.8) Gecko/20010217


The jw wrapper script called by docbook2* blindly prepends
"/usr/share/sgml/docbook/utils-0.6/backends/" to all backend names.  This
makes it impossible for an individual to produce a customized backend for
their own use.

Reproducible: Always
Steps to Reproduce:
Copy a backend from the docbook-utils backend directory to your current
working directory.  Name it something different, like "foo". Then try to
use it, either via "-b foo" or "-b complete/path/foo".  No dice...


Expected Results:  It would be preferable for the -b option to handle
backend selection a bit more intelligently.  At the least, it should
respect any relative or absolute path passed as part of the -b option. 
Over and above that, doing something like proccessing a $PATH-like variable
to select backends might be nice, but I'd personally be satisfied if "-b
some/path/foo" worked... :-)

Comment 1 Tim Waugh 2001-02-23 16:14:24 UTC
Not sure if handling relative paths is a good idea, since it could still be a
system backend.  I have a patch for handling absolute paths properly though.

Comment 2 Glen Foster 2001-02-23 21:51:06 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 3 Tim Waugh 2001-02-24 10:06:09 UTC
Patch applied in docbook-utils-0.6-11.


Note You need to log in before you can comment on or make changes to this bug.