Bug 290791 - NetworkManager would sometimes repeatedly fail to connect
NetworkManager would sometimes repeatedly fail to connect
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
http://www.ces.clemson.edu/linux/f7_s...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 10:06 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 11:41:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2007-09-14 10:06:33 EDT
Description of problem:
As described in "Bug 1." on the given page, NetworkManager would sometimes
receive DHCPNAK from the DHCP server, after which it will consistently fail to
connect to the access point in question. Lease files need to be removed before
it would succeed

Version-Release number of selected component (if applicable):
NetworkManager-0.6.5-9.fc8.x86_64

How reproducible:
Sometimes (depends on hypothesis being valid)

Steps to Reproduce:
1. Get DHCP server to return DHCPNAK
2. Try telling NM to reconnect
  
Actual results:
NM would fail repeatedly

Expected results:
NM should succeed

Additional info:
I have occasionally noticed this problem since FC6 or F7. On the same machines,
though, openSUSE (tested F7 and openSUSE 10.2 on one, F8t2 and openSUSE 10.3b3
on another) has been able to connect much more reliably.

On one really bad wireless router, F7 would fail to connect many times more than
oSUSE, but the problem is less apparent with well-behaved DHCP servers.
Comment 1 Michel Alexandre Salim 2007-11-16 11:41:07 EST
Seems not to be a problem anymore.

Note You need to log in before you can comment on or make changes to this bug.