Bug 290801 - GFS2 [Single Node] Kernel BUG at fs/buffer.c:2813
GFS2 [Single Node] Kernel BUG at fs/buffer.c:2813
Status: CLOSED DUPLICATE of bug 303351
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Steve Whitehouse
Dean Jansa
Depends On: 253008
  Show dependency treegraph
Reported: 2007-09-14 10:09 EDT by Dean Jansa
Modified: 2009-05-27 23:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-16 06:30:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2007-09-14 10:09:13 EDT
Description of problem:

While running g2 on a single node GFS2 fs I hit:

----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at fs/buffer.c:2813
invalid opcode: 0000 [1] SMP 
last sysfs file: /devices/pci0000:00/0000:00:01.0/0000:01:00.0/host2/rport-2:0-r
CPU 0 
Modules linked in: lock_nolock gfs2 autofs4 hidp rfcomm l2cap bluetooth sunrpc d
Pid: 12099, comm: xdoio Not tainted 2.6.18-47.gfs2abhi.001 #1
RIP: 0010:[<ffffffff80019eb1>]  [<ffffffff80019eb1>] submit_bh+0x1f/0x111
RSP: 0000:ffff81003155fa18  EFLAGS: 00010246
RAX: 0000000000000005 RBX: ffff81002f681b50 RCX: 0000000000000000
RDX: ffff81003155fa78 RSI: ffff81002f681b50 RDI: 0000000000000001
RBP: 0000000000000001 R08: ffff81000000bb00 R09: ffff810023179000
R10: 0000000000001000 R11: ffff810023179788 R12: 0000000000000001
R13: 0000000000000000 R14: 0000000000000001 R15: ffff810033ba9900
FS:  00002aaaaacbbcc0(0000) GS:ffffffff80396000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000000009064328 CR3: 0000000030372000 CR4: 00000000000006e0
Process xdoio (pid: 12099, threadinfo ffff81003155e000, task ffff81002f9fc7a0)
Stack:  ffff81002f681b50 ffff81003155fa78 0000000000000001 ffffffff80016c0d
 ffff81002f681b50 ffff81002eca04f0 ffff810023179000 ffff81002eca0530
 ffff81002eca0550 ffffffff8846c765 0000000000000292 ffff81001f65d2c0
Call Trace:
 [<ffffffff80016c0d>] ll_rw_block+0x8c/0xaf
 [<ffffffff8846c765>] :gfs2:gfs2_ail1_start_one+0x127/0x164
 [<ffffffff8846c7fb>] :gfs2:gfs2_ail1_start+0x59/0xc0
 [<ffffffff8846d8a9>] :gfs2:gfs2_log_reserve+0xee/0x18f
 [<ffffffff88469099>] :gfs2:gfs2_glock_nq+0x1a4/0x1ca
 [<ffffffff8847d551>] :gfs2:gfs2_do_trans_begin+0x102/0x144
 [<ffffffff88470c3b>] :gfs2:gfs2_prepare_write+0x1da/0x2a0
 [<ffffffff8000f97c>] generic_file_buffered_write+0x25a/0x6d8
 [<ffffffff80060f39>] thread_return+0x0/0xeb
 [<ffffffff8000ddc3>] current_fs_time+0x3b/0x40
 [<ffffffff80015d6b>] __generic_file_aio_write_nolock+0x36c/0x3b8
 [<ffffffff800df36a>] posix_lock_file_wait+0x20/0xd5
 [<ffffffff8009b44c>] autoremove_wake_function+0x0/0x2e
 [<ffffffff800bdf2a>] __generic_file_write_nolock+0x8f/0xa8
 [<ffffffff80021cf5>] __up_read+0x19/0x7f
 [<ffffffff8009b44c>] autoremove_wake_function+0x0/0x2e
 [<ffffffff80064aad>] do_page_fault+0x4eb/0x81d
 [<ffffffff80061aa4>] mutex_lock+0xd/0x1d
 [<ffffffff80039516>] fcntl_setlk+0x22f/0x25c
 [<ffffffff80043300>] generic_file_write+0x49/0xa7
 [<ffffffff8001617d>] vfs_write+0xce/0x174
 [<ffffffff80016a4a>] sys_write+0x45/0x6e
 [<ffffffff8005b28d>] tracesys+0xd5/0xe0

Code: 0f 0b 68 ba d8 28 80 c2 fd 0a 48 83 7b 38 00 75 0a 0f 0b 68 
RIP  [<ffffffff80019eb1>] submit_bh+0x1f/0x111
 RSP <ffff81003155fa18>
 <0>Kernel panic - not syncing: Fatal exception

Version-Release number of selected component (if applicable):
Kernel 2.6.18-47.gfs2abhi.001 on an x86_64

How reproducible:

Will try to reproduce.

Steps to Reproduce:
1. cd <to_some_gfs2_fs>
2. collie -f /usr/tests/sts-rhel5.1/gfs2/lib/g2.h2

Actual results:


Expected results:

All tests PASS

Additional info:
Comment 1 Dean Jansa 2007-09-14 10:11:53 EDT
This looks somewhat like Bob's comment #2 on 253008, with the exception of the
added posix_lock_file_wait and friends.  Perhaps this is a dup of 008?
Comment 2 Steve Whitehouse 2007-10-16 06:30:17 EDT
Since we have #303351 which is designed to fix the remainder of the jdata issues
that 008 didn't fix, I'm marking this as a dup of that bug.

*** This bug has been marked as a duplicate of 303351 ***

Note You need to log in before you can comment on or make changes to this bug.