Bug 29100 - RFE: smb printer: per user settings
Summary: RFE: smb printer: per user settings
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printconf   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 17:37 UTC by Gerald Teschl
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-25 15:53:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smbprint patch (726 bytes, patch)
2001-02-23 17:42 UTC, Gerald Teschl
no flags Details | Diff
C src file (646 bytes, text/plain)
2001-02-23 18:01 UTC, Gerald Teschl
no flags Details
smbcat.c (more secure version) (748 bytes, text/plain)
2001-02-23 18:45 UTC, Gerald Teschl
no flags Details

Description Gerald Teschl 2001-02-23 17:37:57 UTC
I just had the problem that I need per user settings (username/password)
for a smb
printer. Unfortunately printconf does not support this. Hence I changed
 /usr/share/printconf/smbprint to read in a user config file
(~/smbprint.conf) if available.
The only problem is that the user config file should have mode 600 since it
contains
the windows user password. Hence I also need a little suid root c wrapper
to read
in the config file (this wrapper must be executable by group lp only).

I will attatch the patch to smbprint and the src for the c wrapper to this
request.

Comment 1 Gerald Teschl 2001-02-23 17:42:39 UTC
Created attachment 10820 [details]
smbprint patch

Comment 2 Gerald Teschl 2001-02-23 18:01:25 UTC
Created attachment 10821 [details]
C src file

Comment 3 Gerald Teschl 2001-02-23 18:03:14 UTC
The wrapper must be stored as /usr/share/printconf/smbcat

[root@soliton /root]# ls -l /usr/share/printconf/smbcat
-rws--x---    1 root     lp          14655 Feb 23 19:58
/usr/share/printconf/smbcat*

Comment 4 Gerald Teschl 2001-02-23 18:45:59 UTC
Created attachment 10840 [details]
smbcat.c (more secure version)

Comment 5 Glen Foster 2001-02-23 21:49:38 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #2


Comment 6 Crutcher Dunnavant 2001-02-26 01:22:43 UTC
No.

This capability, to have meaning, would require printconf to use LPRng's
authentication system. It does not. Since it does not, it is trivial to
lie about who you are to the printer. While this is the case, your patch
gains you no additional security.

While I would like printconf to gain the ability to configure LPRng's
authentication settings, this would require a good deal of additional
engineering, and will not happen by the next release.

Sorry, but I will keep this desire in mind.

Comment 7 Gerald Teschl 2002-05-24 11:44:30 UTC
I still would need this feature.


Note You need to log in before you can comment on or make changes to this bug.