Bug 291131 - Widelands build-11 released
Widelands build-11 released
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: widelands (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: Karol Trzcionka
Fedora Extras Quality Assurance
http://xoops.widelands.org/modules/ne...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 11:57 EDT by Nils Philippsen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0-0.7.build11.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 13:59:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2007-09-14 11:57:29 EDT
SSIA
Comment 1 Nils Philippsen 2007-09-14 11:59:49 EDT
I found that then new version was available while browsing happypenguin.org.
Comment 2 Till Maas 2007-09-14 16:30:58 EDT
I get this error when I want to play it using the rpm from updates-testing,
build-10 works without a problem.

Section [global], key 'single_watchwin' not used (did you spell the name correctly?)
Section [global], key 'EXENAME' not used (did you spell the name correctly?)
Sound_Handler: loaded song "music/intro_00.ogg"
Sound_Handler: loaded song "music/menu_00.ogg"
WARNING: Couldn't open pics/progress_bg.png: Could not find file: could not find
file or directory: pics/progress_bg.png
WARNING: Couldn't open pics/progress.png: Could not find file: could not find
file or directory: pics/progress.png

Caught exception (of type '11_wexception') in outermost handler!
The exception said: src/graphic.cc:330 get_resized_picture(0): picture doesn't exist

This should not happen. Please file a bug report on version: build-11.

lastserial: 0
WARNING: Hardware shutting down although graphics system ist still alive!
Comment 3 Karol Trzcionka 2007-09-16 11:06:21 EDT
Please any info about the machine. On my computer (i386) all works fine, my
friend tested it on x86_64 and it works correct too. He has a problem with yum
update (the game returns the same error), but after reinstall it is ok.
Comment 4 Till Maas 2007-09-16 12:11:21 EDT
I have an system i386, too. It works, after I removed the old widelands, removed
my .widelands directory and installed it again.
Comment 5 Nils Philippsen 2007-09-17 05:17:01 EDT
I think the problem was having the maps as unpacked directories in the old
release and having them as single files with the same name in the next. RPM
can't handle that by itself, you need to remove the directories and their
contents in %pre in the new version, e.g. like this:

--- 8< ---
%pre
# prepare transition of maps from unpackaed directories to single files with
# the same name
cat << EOF | while read name; do rm -rf
"%{_datadir}/widelands/maps/${name}.wmf"; done
Checkmate
Dry Riverbed
Elven Forests
Enemy in sight
Finlakes
Firegames
Four Castles
Glacier Lake
Golden Peninsula
Lake of tranquility
Plateau
Riverlands
The Oasis Triangle
The big lake
The long way
Two frontiers
War of the Valleys
EOF
--- >8 ---

This needs to be fixed because it renders the package not updatable.
Comment 6 Fedora Update System 2007-09-17 23:17:19 EDT
widelands-0-0.7.build11.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2007-09-24 13:59:25 EDT
widelands-0-0.7.build11.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.