Bug 291211 - Monitor goes to power save mode when X starts
Monitor goes to power save mode when X starts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 12:27 EDT by Kenneth A. Redler
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 03:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log from failure (152.67 KB, text/plain)
2007-09-14 12:27 EDT, Kenneth A. Redler
no flags Details
Xorg.0.log for Radeon R100 QD [Radeon 7200] (41.09 KB, text/plain)
2007-09-16 09:52 EDT, Joachim Frieben
no flags Details
Xorg.0.log from successful run (52.85 KB, text/plain)
2007-09-24 10:44 EDT, Kenneth A. Redler
no flags Details
Xorg.0.log for Radeon R100 QD [Radeon 7200] (45.75 KB, text/plain)
2007-09-24 16:59 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Kenneth A. Redler 2007-09-14 12:27:54 EDT
Description of problem:
Booted F8t2 i686 LiveCD.
Text mode was working during kernel boot.
Monitor switched to power save mode when X started up (after udev [OK] message)

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.7.192-1.fc8

How reproducible:
Always

Steps to Reproduce:
1.  Boot F8t2 i686 LiveCD.
2.  Wait for X to start.
  
Actual results:
My Dell 2407WFP driven by an ATI X600 card via DVI goes into power save mode.

Expected results:
Login/Desktop should come up when X starts.

Additional info:
This is a Dell Optiplex GX620 w/ an ATI x600 card(dual monitor capable...only
one monitor hooked up.

tty's 1-6 & 8-12 work fine (able to log in on 1-6, blinking cursor on higher
ones)

Chatted with 'halfline'(rstrode@nat/redhat/...) on irc.freenode.net in
#fedora-devel.  He suggested I try using xrandr to change resolution, so I 
set DISPLAY=:0 and tried 'xrander -s 1' from tty2.  All I got was the screen
blinking crazy for a while and tty7 still goes to power save mode.

I have attached xorg log.
Comment 1 Kenneth A. Redler 2007-09-14 12:27:54 EDT
Created attachment 196011 [details]
xorg log from failure
Comment 2 Joachim Frieben 2007-09-16 09:52:52 EDT
Created attachment 196711 [details]
Xorg.0.log for Radeon R100 QD [Radeon 7200]

Same problem here with an ATI Radeon AIW 7200 [R100]. However, I am unable to
switch to a text console. Well, at least, the monitor stays off. It is still
possible though to reboot the system via ctrl-alt-del. Unlike in the original
report, there is a backtrace in my Xorg.0.log file near the end. Switching DRI
off doesn't make a difference either. Reverting the driver package to version
6.6.3-4.fc8 from F8T1 allows to restore normal operation.
Comment 3 Joachim Frieben 2007-09-16 09:56:43 EDT
(In reply to comment #2)
The monitor is connected to the [only] VGA output.
Comment 4 Joachim Frieben 2007-09-20 07:25:39 EDT
No improvement for xorg-x11-drv-ati-6.7.193-1.fc8.
Comment 5 Joachim Frieben 2007-09-24 08:59:23 EDT
No improvement for xorg-x11-drv-ati-6.7.194-1.fc8.
Comment 6 Adam Jackson 2007-09-24 09:28:30 EDT
Does updating to xorg-x11-server-Xorg 1.3.0.0-24 help?  The EDID parser had at
least one egregious bug in -22.
Comment 7 Kenneth A. Redler 2007-09-24 10:44:31 EDT
Yes, I booted the f8t2 liveCD into single user mode; executed 'init 3'; used yum
to update xorg-x11-server-Xorg,xorg-x11-drivers, and xorg-x11-drv-ati; executed
'init 5'.

The login screen came up as expected.  Thanks for the assistance ajax!

I have also attached /var/log/Xorg.0.log from this time around.
Comment 8 Kenneth A. Redler 2007-09-24 10:44:47 EDT
Created attachment 204211 [details]
Xorg.0.log from successful run

After updating xorg-x11-server-Xorg to 1.3.0.0-24(along with xorg-x11-drivers
and xorg-x11-drv-ati), here's the xorg log from a successful run.  I was able
to see the login screen and actually login.
Comment 9 Adam Jackson 2007-09-24 10:47:06 EDT
Awesome, thanks for testing!

Marking as fixed in rawhide.  Anyone else who's experiencing this, please update
to xorg-x11-server 1.3.0.0-24 or later and test, and reopen if this is still a
problem.
Comment 10 Joachim Frieben 2007-09-24 16:59:37 EDT
Created attachment 204561 [details]
Xorg.0.log for Radeon R100 QD [Radeon 7200]

Xorg.0.log for a fully updated -rawhide- system including ATI driver version
6.7.194-1 and X server version 1.3.0.0-24.fc8. Impossible to start X, still the
same backtrace a the end of the file. The monitor is a 21" HP A4756A CRT
display and a [single] corresponding screen mode of 1400x1050 pixels has been
added to the otherwise unaltered xorg.conf as.
Comment 11 Joachim Frieben 2007-09-25 01:34:01 EDT
(In reply to comment #9) 
> Marking as fixed in rawhide.  Anyone else who's experiencing this, please update
> to xorg-x11-server 1.3.0.0-24 or later and test, and reopen if this is still a
> problem.

The bug ist still there [comment #10] but I'm not entitled to reopen the bug.
Comment 12 Matěj Cepl 2007-09-25 03:33:07 EDT
OK, show goes on :-).
Comment 13 Matěj Cepl 2007-09-25 03:36:57 EDT
Actually, no, it doesn't. This is different problem, then what's described
above. The bug we are dealing with here didn't include any crashes.

Joachim, could I ask you to file a new bug (after search, whether there isn't
duplicate of it)?

Note You need to log in before you can comment on or make changes to this bug.